WizFi250 UART / SPI selection issue

I am using the WizFi250 with the SPI interface only. This works but on rare occasions the module will reboot. I was finally able to track this down to the WizFi250 receiving HF noise on the open UART RXD pin. Then it thinks a character was send on UART and reboots. I can prevent this by wiring the RXD pin to ground but would like to know is there is a software solution so it will ignore the UART completely as we have maybe 1000 WizFi250 in the field and adding a ground wire to all of them would be quite a mess… Setting AT+MSPI=2 does not seem to make any difference. Firmware in use is

Thank you!

Hello @Sebastian

As mentioned to us, there’s no way to set SPI/UART interface other than ‘AT+MSPI’ AT command.

Therefore, it should be solved by fixing H/W.

I’m sorry I couldn’t help you.