WIZ750SR-110 does not save configuration

I bricked my WIZ750SR-110 by uploading a bad bin file.
I was able to reload WIZ750SR-1xxv133_incl_Boot.bin using ISP
I can connect with wizconfig-V1.5.0.exe, but MAC address is FF:FF:FF:FF:FF:FF, and when I change settings and Apply Settings, it reverts to factory defaults on restart.
I have also tried command line serial commands with the same result.
Any idea why it won’t retain settings?

I was able to recover from this by using W7500ISP:
select ISP->Dump->Data Dump from top menu bar
Edit resulting data_flash.bin with a Hex editor, insert MAC address staring at offset 0
Under Step 2 - Erase: Check Erase Data0 & Erase Data1then click Start Step 2
Under Step 5 – Select Binary FIle: select Binary File as edited data_flash.bin by using Browse button
Check Write DataFlash
Click Start Step 5

This was Version of W7500 ISP Tool, file “W7500_ISP_20180731.exe”

I hope this helps someone else.

1 Like

Thanks for telling me a good way.
I will show you how to insert MAC using ISP tool.
You can check it out in the video below.