WIZ107SR S2E Not Communicating

Dear Team,

Ethernet to TTL and TTL to Ethernet not working.

I have purchased few modules of WIZ107SR for ethernet to TTL. I am able to configure each module and set IP, server mode, have set baud rate, etc.

However, when I try to send data by creating socket connection via ethernet, at TTL end data is not received.

Similarly, when data is sent from TTL, keeping socket connection, data is not received at ethernet end.

As seen below command 123, MAC address ASCII and MAC address HEX command also did not worked.

May I request you to please help me to confirm setup. At this moment I am not able to make any progress.

Thanks in advance.

Nilesh Korde

Hi @nileshakorde,

If the firewall is on, data would not be sent.
Please check the firewall status and turn off it, and test again.

For the serial command mode, When using the Hercules tool you can use the CR/LF with $0d$0a like below.
To check the operation, change the view settings in the tool and check. And try sending it in the Send window at the bottom as follows.

Thanks Rena for prompt support.

Unfortunately, suggested steps did not help me to establish communication to LAN module from serial port.

Please find detailed setup and steps at my end.

Firewall being put OFF

WIZ100SR module configuration using Configuration Tool

Hercules utility connected to module in one PC as TCP Client

Second PC using Hercules Serial and setting are as shown below

Uploading: 105HerculesSerial1.png…


Second PC using Hercules Serial and setting are as shown below

Data is sent from serial to TCP, however data received by TCP client is corrupt. Though corrupt data received, data received at TCP is same each time.

Similar data corruption occurs when data is sent from TCP to TTL/serial.

Note that to confirm I have changed baud rate to 9600 while transferring data.

Also, when I try to read mac or version using serial commands, I do not get any response from module.

The Baud rate seems to be set incorrectly in this part.
Could you try changing it to a different Baud rate setting?

And, if the debug message option is enabled, a message should be output through the serial port like below.
There seems to be a problem with serial communication.

How are PCs and devices connected?

Please guide me how to enable debug messages option

I have tried with different baud rates but get similar results. Also tried with different serial tool instead of Hercules.


I have checked documentation and settings and found Debug Mode was already on. Same can be seen in earlier shared screen shoots. I am sharing fresh screen shoot again.

Yes, I checked the debug option already enabled.
But the firmware version is very low.

I think you have to upload the latest firmware(v4.0.6) first.
Please download the F/W file and upload with Config Tool.


Now I have pasted correct screenshot. FirmwareVersion is 4.06 at my end.

Earlier image was just to represent Debug Setting which has caused by confusion. Sorry for that.
Now I am aware of Debug Message Output setting, but I am not getting desired result.


Request you to provide response asap. If you have any India partner or team out here in India than please help me to connect with them.

We are completely stuck, and our project is not progressing. We are working on few repeat orders using this module and our design, development, enclosure is completely based on this module.

We have used earlier same modules and delivered.

Trying out any other modules at this stage, and 11th hour is challenge for us.

Thanks in advance.

It is difficult to determine the problem…
You can try a factory reset.
The settings will be reset with factory default, so you can set the default options and test.
I think you have to also check the device connection.

WIZnet’s India branch is placed in Bengaluru.
You can contact with WIZnet India team. Please refer to the below link.


As suggested Factory Reset step, I have carried it again and left baudrate default.

Data received at both end TCP and SERIAL end is corrupted.

The symptom seems to be that the serial communication is abnormal.

Is the module TTL version? Or is it RS-232? Please check it.
If the communication level is not right the data could be broken.

Using USB to TTL CP2102 (HW 598)

Also as suggested tried with another USB to TTL but that gave similar results. Data received at both ends is corrupted.


I have followed India support last two days and they will be forwarding issue we are facing to HQ.

We have client delivery this week.

Though there is support provided by with forum support, and India team, we are not able to address issue discussed.

Thus your guidance to get issue resolved will be of great help.

Thanks in advance.

Nilesh Korde

  1. Check the module type again. It is one of the major causes of data corruption.
    The TTL version should not have an RS-232 transceiver.
    If the device has a transceiver, you have to use a USB to RS232 module, not a TTL module.

  1. If possible, please attach a picture of the device connection.


Please see attached top and bottom view of module.

It has chip in highlighted area.

Please share steps or documentation how to use this module.

Also share how to convert this module to TTL. We need to use this with embedded hardware where TTL inputs board designed.

Nilesh Korde

Please find device connections.

The module is of RS-232 type.

TTL version module sold separately. You can use that.
Is there any reason to use the RS-232 version module?

We have received these modules and after our forum communication found that we received ethernet to RS232.

Can you please provide block diagram or schematic for connecting LAN module (ethernet to RS232) to TTL so that we can build circuit accordingly.

If the modules with us can be modified by removing some components, then that suggestion will also work for us.

Nilesh Korde