W5500-io to rj45 issue

Hi everyone. We have an issue and need your help on the same. We have a custom board with STM32 microcontroller and we have connected a w5500-io board to it. The w5500-io board is the one which has everything on it except the rj45 connector.

If I connect the w5500-io to an external rj45 then somehow the connection remains unresponsive. However if we take the MISO, MOSI, SCK, CS, 3.3V & GND from the base board and connect to a full w5500 shield which has the rj45 built into it then it seems to work fine. So connections upto the w5500-io are right including the code.

Can someone pls guide if the rj45 can be connected directly to the w5500-io without need for any other components. If someone could guide on possible reasons for failure it would help. We are unable to ping the controller either.


Part number for this external connector? Does it have magnetics inside?

You have W5500-io circuit diagram, and you have W5500 chip recommended circuit diagram. Compare to find out what you do wrong. Probably you confuse TX and RX wires.

We tried 2-3 connectors with magnetics and without magnetics. But the result was the same. But to be precise one of the connector is the LINK-PP LPJ0026GENL. The connector drawing is as below. Our connection is as mentioned below

W5500-IO. RJ45 connector
RX_P. RD+ (7)
RX_N. RD- (8)
RCT. CT(6)
RCT. CT (3)
TX_P. TX+ (1)
TX_N. TX- (2)


Try different type of LAN cable. See 5.5.6 of the datasheet.

Sorry I made a mistake. It’s TCT → CT(3)

Tried with a different cable also but didn’t really help. Actually this cable did work with the w5500 full shield with rj45 in it. So cable shouldn’t be the issue I guess.

Ok if we ruled out simple possible issue causes then deeper dive is required.

Are both boards powered from same power supply?
There’s reset pin. Is it connected the same way as for the shield?
Does STM32 read registers properly - in other words does digital part of W5500 work or not?
Do you happen to have other (type of) transformer to try or ideally the jack used in the reference W5500 circuit to try?