WIZnet Developer Forum

WIZ107SR UDP many clients problem - differences 4.02-4.03 FW

Hello.
I have WIZ107SR modules, H/W version 1.4, firmware version 4.03 (date of production 2013).
Previously, I used the modules in H/W version 1.1, firmware version 1.9 – and everything worked properly.
Now I have problem – in UDP protocol I can’t connect (send bytes) from many computers (clients).
Module communicates (accept data) only from one computer – whose the IP address is entered in the field “Remote IP/host name”.



In old version of modules I can communicates from many computers (clients) without problem.
In my solution I have to connect to the module with a few laptops and tablets.
How to solve it?

Added: 08.08.2014
I checked the modules with firmware 1.9 and 4.01 and working properly.
It seems that version 4.03 has a bug!

Best regards,
Adam

Hello Adam,

I’m sorry to hear your difficult situation.
But, I need to explain what was wrong in detail.

In UDP mode, WIZ107SR originally was designed to communicate with its peer system in both direction.
It can receive data from its peer system via an UDP socket as well, it can send data to its peer system too.

Until FW 4.02, WIZ107SR didn’t consider its destination IP address and port number to communicate.
So in like your circumstance, there was no fault in communication with multiple clients.
However, if you wanted to send some data to one of systems whose address is not written on WIZ107SR’s remote IP address field, you couldn’t send it.
Frankly speaking, WIZ107SR’s FW 4.01 had a bug making some fault to communicate with its peer system via UDP.

We fixed it with FW 4.03 and WIZ107SR drops all data from different one with its remote IP address.

In fact, we didn’t consider that WIZ107SR communicate with multiple devices via UDP.
It is allowed to send and receive data via UDP socket with only one device at once.
It may be not proper to use WIZ107SR for communication with multiple UDP devices.
If you use FW 4.02, you can receive data from multiple UDP devices but sending data to multiple destinations will be failed.

So, If you want to communicate with multiple devices via UDP, I recommend you use WIZ550S2E with the combination of AT command mode.

I hope you to solve the problem.

Thank you.

James.

Hello James.

Thank you for clarifying the subject.
Therefore, you should put on their web pages two versions of firmware: 4.02 and 4.03 - with explanation of how they work.

In my opinion the module should not work as modem or transceiver. This is “Ethernet To Serial” module and should accept data from the entire network - not from a single device on the network.

Best regards,
Adam

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.