W5500-EVB-Pico not enterring bootloader mode

I am trying to connect to a W5500-EVB-Pico board and set it up for Circuitpython. I assumed that since it is a Pico it would follow the same process as a normal Pico (hold BOOTSEL, plug in USB, release BOOTSEL), but that is not working. The board is powering up but it is not registering as a storage drive like any other Pico (I am using the same cable and port I have used for 5 other Picos in the last week).

I did notice that on plugging the Pico in I get two additions to my Device Manager (Win 11). The expected entry for a new Com port show up, and also an entry under “other devices’ labelled 'Reset”. Any help would be greatly appreciated.

1 Like

Make sure the BOOTSEL goes low when you click the BOOTSEL SW.

Did you solved this, i have same issue

Ok, bought three units from Mouser, and none of the three had two properly working buttons!
On one the reset was not working, on two the bootsel did not work. Solved by resoldering the buttons.
But did not expect this from a product in 2024. Seriously undermines one’s confidence. And wasted about an hour trying to get it working and soldering…