Is there a way to increase power?

#1

Using firmware 1.0.1.8

We are using a point to point link sending data in udp mode. We are finding that packets are randomly not getting through.
It is sending 66 packets a second.
It is as though it uses just enough power to send almost all the packets, but not quite all of them. If we put the 2 modules close together, all the packets get through. Further away, it drops some, and it seems that increasing the distance does not make much difference - it increases the power to get most of them through, but not quite enough.

Is there a way to force the module to maintain a higher power transmission ?

This is the response to at+mwifips
at+mwifips=?
0,0
[OK]

Are there any other at commands that might be influential ?

#2

Perhaps you could use the at command AT+WBGN

wizwiki.net/wiki/doku.php?id=pro … et#at_wbgn

I don’t know how to use it though, the website does not give any details, just recommends that you should not use it unless it’s absolutely necessary - in your case it might be…

#3

Hi anglial

How about trying it again after changing the antenna-option?

  • Try it using a dipole antenna.
  • Issue <AT+WANT=0> command. (Fix a antenna type instead of auto-antenna)
    AT+WANT Antenna Configuration =? or = (0:uFL,1:PA,3:Auto)
#4

Thanks I will try using the AT+WANT command today.

I would like to see what affect AT+WBGN has as well

The AT+WBGN command accepts 0,1 or 2
What do the 0,1 and 2 refer to ?
Is there a default ?

at+wbgn=0
[OK]
at+wbgn=1
[OK]
at+wbgn=2
[OK]
at+wbgn=3
[ERROR: INVALID INPUT]
at+wbgn=?
[ERROR: INVALID INPUT]

#5

Hello anglial

You can fix a b/g/n WiFi mode using below command.
You should issue this command before AT+WJOIN.

But, I’m not sure that this can solve your problem.

AT+WBGN : WiFi 802.11bgn mode Configuration = (0:bgn, 1:bg, 2:b)
Ex)
AT+WBGN=2
[OK]