WIZnet Developer Forum

WIZ127SR setting character delimiter problem

Hello everyone!

I have problem with setting up character delimiter in my WIZ127SR. There is no way to do it by WIZ127SR config tool (I use ver 1.0.0.2) so I’m trying to do this by serial command configuration mode. When i start communication via serial everything is working fine. I’m sending command:<OC0F>, WIZ is sending me <S> so according to official documentation everything should be ok. But it is not. When I check character delimiter using:

<QC> it gives me back:<S00> Which means that character delimiter is still off. I tried to restart wiz using: <WR>after setting charater, but after reboot character is still set to ‘00’. Also tried to change time delimiter to something else than 0 and then set character delimiter - no success. I have no idea what am I doing wrong. Is there any special command which should I use before setting this delimiter? Same thing is happening when I’m trying set up size delimiter.

I don’t know if it matters, but my WIZ is working in UDP mode.

If you have any questions about things I forgot to write please ask. Is there any chance that my WIZ127SR is broken?

Thanks for help.

I’m wondering the status of this isse.
If this issue is remain now, please post a new topic in Forum.
I will check a new topic immediately.

Thanks.

I solved this problem by buying wiz 145SR. On 127SR it just didn’t worked. So there is two options: my wiz127SR was broken, or datasheet is not correct.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.