No link and LEDs are light-up with no cable plugged-in(W5500))

I need help guys. Currently am trying to get up and running W5500 chip on my custom PCB, but behaviour of chip is extremely unstable:frowning:
Initially right after soldering it worked for about 5-10 minutes, but now it just glowing all LEDs even without ethernet cable plugged in. When i plug the cable in - nothing changing. Link is down also. Don’t know where to dig up the problem.

Schematic and pcb layout attached, appreciate if you’ll find mistakes i don’t see:
Don’t look at abscent 1M resistor near crystal(it works)





PS: Actually this is 2nd revision of pcb, previous had similar issues, plus couple chips were burned due to wrong tx/rx pull-up resistors(ICs were heating like hell with 0.55A consumption).

If chip did not die because of overheating (or any other issue like shortage), then there’s some contact issue. Use magnifier/microscope to examine the soldering. Where’s R26? Hopefully oscillation circuit did not fail because of its missing.

R26 is in place. Oscillation is working well(even without R26). Chip was brand new, and it worked well for a while, before malfunction. I just don’t get why. Voltages are fine, SPI connection working. There are no any shortages or something, soldering is pretty clean.
Maybe it’s RSVD pins pulldown resistors values? I tried 10k, shorting to GND and left unconnected as well(in datasheet they should be NC except pin 23).Same behaviour. I even have bought arduino module with W5500, to just reverse it’s schematic. But schematic is the same, lol.

image

So chip is not dead, something is going on with PHY.
What PHYCFGR says?

I do not think so but you have placeholders and can play with them. But it seems you have done it.

Did you check analog 3.3V?

Hi again!
I decided to just check and solder most of caps from working chinese module(RSVD pull-up resistors as well). TOCAP capacitor is 100nF on chinese module, but should be 4.7uF regarding to datasheet, but i soldered it on my board as well(these modules are working somehow, so why not).
I’ve also soldered new chip and R26, clock is fine, 25MHz on oscilloscope.
PHYCFGR is 0xB8(0b10111000) with cable plugged-in and 0xBA(0b10111010) without cable.
So LINK is down :frowning:
Analog 3.3V is fine, digital as well(added extra 4.7uF caps).
BUT, after some time all leds started glowing again and chip became inaccessible over SPI, MISO is always LOW. I’ll check soldering tomorrow, but seems it’s fine at quick glance.

Is it 3V (as in circuit) or 3.3V? While datasheet is stating operating voltage of 2.97 to 3.63, I’d be cautious as chip heats over time and may have issues at 2.97 or will require more current on lower voltage and would heat even more.

Do you supply enough current to the chip?