WIZnet Developer Forum

Serial Command Mode Crash

Hello Support,

I’m have two problems with the serial command mode when using the WizFi630 reference board.
Problem #1
For my first test I configured serial port P1 (UART1) to “command mode” and setup the UART to no flow control mode (configured from the webpage and in the serial terminal). Now I send some commands
<Sv1.1.28><Sv1.1.28><Sv1.1.28>
You can see that the wizfi630 module didn’t respond.
If I look at the CTS command line it is toggeling implying CTS/RTS flow control is used, but I don’t have this configured. (If I configure flow control mode the problem still persists)

If I use P2 (UART2)
<Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28>
UART2 always works, so is there a problem with UART1?

Problem #2
Using the same configuration on serial port P2 (UART2)
<Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28>>
Notice that I sent an extra ‘>’ out of sequence. Once this happened the Wizfi530 module doesn’t respond to any more serial commands until I reset it. Have I set it into an obscure mode and is there a work around through the serial port? Once this happens the UART activity light stops flashing when I send characters.
Incidentally this happens on UART1 as well.

(Just in case it matters I’m using H/W-GPIO for and I have the Command mode option set => <Serial Port #1> => => => Enable)

Thankyou for you time
Paul

Hello Paul

(1)
I couldn’t reproduce what you said.
What is the serial-terminal-tool which you used?
How about try it again with another terminal-program?

(2)
I’m not sure why the module didn’t respond.
But, about this issue, I want you to confirm the response for each command.

Hello,

I have resolved Issue #1. I was using a ATEN usb to serial converter, it doesn’t like the flow control connected but not used. My resolution is to only connect the TX, RX and GND pins, then the terminal is almost perfect (issue #2 remains)

As for Issue #2:
I have set my terminal program to echo my typed characters here is the response:
<Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28><Sv1.1.28>
<Sv1.1.28><Sv1.1.28>[color=#FF0000]>[/color]<RF

<RF

Notice the extra ‘>’ that I have sent. After this the module doesn’t respond on serial again until I reset.

(I’m using real term, but the problem exists for HyperTerminal and putty, infact I’m trying to use the module with an embedded MCU, and this is where I found this problem. My MCU was communicating with module before it was powered and running, sometimes the module didn’t respond. Upon debugging I discovered this feature)

Thanks,
Paul

Hello

I tested it again.
As you said, after extra “>”, WizFi630 didn’t respond, but after some seoncds, it responded it after some seconds.
Refer to the below. (I tested it with v1.1.31)

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.