WIZnet Developer Forum

Wiz550io no socket control

I seemed to have lost almost all control over the socket registers. I cannot set the IP address or destination port number on any of the sockets. I also see no status change when I send the “OPEN” command. I can change the socket mode and source port number. I have tried altering other sockets with the same result. I can read and write other registers freely (like common register or even transmit and receive memory on any of the sockets). I had it working before but now I’m completely blocked. I’ve been rewriting code for days, checking wiring, tried multiple Wiz550io modules (fresh out of the box) . . . No luck! What could possibly be preventing me from changing socket destination parameters yet still allow me to change practically everything else? I’m using an ATmega324A chip. Code is attached. I suspect there’s a simple explanation that I just can’t see because I’m looking to close at the wrong spot.
src.zip (9.37 KB)

Hi,

Destination port and IP can be read after TCP connection is established.
First, try to connect and then check registers.

Thanks.

Thank you. Now I understand. So I’m able to see registers now but still can’t seem to connect like I did before. I’m getting a timeout flag on the socket. My firewall shows no packets coming from the switch. I suspect the issue is with something other than the Wiz550io now, but in case I’m missing something obvious again, here are the settings I’m using.

Subnet mask: 255.255.255.0
Gateway IP: 192.168.2.1
Source IP: 192.168.2.3

Socket 0
TCP
IP address: 192.168.2.2
Source/Destination port: 31415

Everything else uses default values set by hardware reset.

Ignore that last post. I just connected. I suspect I tried to connect too soon after giving the “open” command. Thanks again.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.