[From QnA] Problem in using WIZ145SR


#1

Sir,
Iam Using WIZ145SR (Serial to Ethernet Converter(Four Port Addressing)) for My Current Run Application.Iam Accessing Entire Four Ports in my Application.The Problem is in Switching the Ports Contiously through out the Application.In switching from one port to another the Data send to one port is found on other port .is there any time Delay in Switching the Ports.if in case ,while transmisson we can handle the Delay but in receiving the whole thing is dependent on the Wiz… Module , in this case the Module is Gettng Hanged and after that it is disconneted from the Application,i can see visually the Led Blinking on the module which use to appear when it is inpoer on Condition,Kindly Make this as a Note and Feed back me ASAP as my Project is under Pilot Run .


#2

Dear customer,

1> Please select more faster baudrate and have a try, such as 115200.
2> I would like to clear a question:You said that while transmisson we can handle the Delay but in receiving the whole thing is dependent on the Wiz… Module. Where “transmisson” means your target board sends serial data to Wiz device? “recv” means Wiz device receive ethernet data from network device, right?
Thanks.
WIZnet


#3

Sir,
Ref to Point # 2 , “Transmission” means Network device to Wiz Device thorough Ethernet, and “Recv” Means receiving Data from Target Board to Wiz Device through Serial port ,Here the main problem is the four Target Device Sends Data simultaneously to Wiz Module through their own Serial Ports Repsecteivly .here what is the case of switching the ports ? we had no problem while using single Port but the problem arises when we are connected to all ports ,Presently we configured the Wiz Device to 38400 Baud Rateand Running, As u said i will reconfigure it to 115200 and will test and report u back but kindly Acknowledge me on this ASAP .

Thanking You
With Regards
Anil T Shetty