[From QnA]Connecting to the Google Web server


#1

How can I connect to the google HTTP serer(Port 80) using <AT+NCTCP> command?


Connecting to the Web server
#2

(1) Basic Information (Check FW version)

[quote]ATI2
WizFi210
1.2.0.3(S2WEAP)
[OK]
[/quote]
(2) Association

[quote]AT+WD
[OK]
AT+WA=WizFiDemoAP
IP SubNet Gateway
192.168.3.109: 255.255.255.0: 192.168.3.1
[OK]
[/quote]
(3) Set Time and Get IP address

[quote]AT+SETTIME=10/09/2013,13:11:11
[OK]
AT+DNSLOOKUP=m.google.com
IP:173.194.72.193
[OK]
[/quote]
(4) Connect google HTTP server (Port : 80)

[quote]AT+NCTCP=74.125.31.193,80
[CONNECT 0]

[OK]
[/quote]
(5) Get HTTP data using

[quote][color=#FF0000]{1B}S0GET / HTTP/1.1{0x0d}{0xa}{0x0d}{0xa}{1B}E[/color]

HTTP/1.1 302 Found
Location: google.co.kr/?gws_rd=cr&ei=C … kQWdt4DoDg
Cache-Control: private
Content-Type: text/html; charset=UTF-8
Set-Cookie: PREF=ID=84d062b98340e514:FF=0:TM=1378789131:LM=1378789131:S=a68M64yliEHh_igB; expires=Thu, 10-Sep-2015 04:58:51 GMT; path=/; domain=.google.com
Set-Cookie: NID=67=KACCneN7r_AwtDZuHX70g9OWS_n9S7qgMns9Krix5tGuzJz0PaahhNwwu2GKV5dOSlENidatT9uHHNGH94VwFli-5dnswrUMq5V5uvf_W20fVC8NipSbxu5dvN6sKnKa; expires=Wed, 12-Mar-2014 04:58:51 GMT; path=/; domain=.google.com; HttpOnly
P3P: CP="This is not a P3P policy! See google.com/support/accounts/ … wer=151657 for more info."
Date: Tue, 10 Sep 2013 04:58:51 GMT
Server: gws
Content-Length: 261
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Alternate-Protocol: 80:quic

302 Moved

302 Moved

The document has moved here. [/quote] (6) Close TCP Connection [quote]AT+NCLOSEALL [OK][/quote]

#3

Then, how can I connect to the Google HTTPS serer(Port 443) using <AT+NCTCP> and <AT+SSLOPEN> command?


#4

(1) Basic Information (Check FW version)

[quote]ATI2
WizFi210
1.2.0.3(S2WEAP)
[OK]
[/quote]
(2) Association

[quote]AT+WD
[OK]
AT+WA=WizFiDemoAP
IP SubNet Gateway
192.168.3.109: 255.255.255.0: 192.168.3.1
[OK]
[/quote]
(3) Set Time and Get IP address

[quote]AT+SETTIME=10/09/2013,13:11:11
[OK]
AT+DNSLOOKUP=m.google.com
IP:173.194.72.193
[OK]
[/quote]
(4) Connect google HTTPS server (Port : 443) and open a SSL session

[quote]AT+NCTCP=74.125.31.193,443
[CONNECT 0]

[OK]
AT+SSLOPEN=0
[OK]
[/quote]
(5) Get HTTPS data using

[quote][color=#FF0000]{1B}S0GET / HTTP/1.1{0x0d}{0xa}{0x0d}{0xa}{1B}E[/color]

HTTP/1.1 302 Found
Location: google.co.kr/?gws_rd=cr&ei= … lQXBjIGADA
Cache-Control: private
Content-Type: text/html; charset=UTF-8
Set-Cookie: PREF=ID=cd6b84ea92e31f22:FF=0:TM=1378790022:LM=1378790022:S=OVjrgP0A_HmPFcrZ; expires=Thu, 10-Sep-2015 05:13:42 GMT; path=/; domain=.google.com
Set-Cookie: NID=67=b2GN4OS8bTRLVcSUxs2zRJtm1UUP9_E4y-H1W-80Ef5uy0yGF3Lxs3KQGFXdDf-rjle941GgNMA_3UoDqKB5nR_7yI9Hm8dam-lB9xn0Wr6VzKn8PQ72uf-k5E3YoB21; expires=Wed, 12-Mar-2014 05:13:42 GMT; path=/; domain=.google.com; HttpOnly
P3P: CP="This is not a P3P policy! See google.com/support/accounts/ … wer=151657 for more info."
Date: Tue, 10 Sep 2013 05:13:42 GMT
Server: gws
Content-Length: 262
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Alternate-Protocol: 443:quic

302 Moved

302 Moved

The document has moved here. [/quote] (6) Close TCP Connection [quote]AT+NCLOSEALL [OK] [/quote]

#5

(1) Basic Information (Check FW version)

[quote]ATI2
WizFi210
1.2.0.3(S2WEAP)
[OK]
[/quote]
(2) Association

[quote]AT+WD
[OK]
AT+WA=WizFiDemoAP
IP SubNet Gateway
192.168.3.109: 255.255.255.0: 192.168.3.1
[OK]
[/quote]
(3) Set Time and Get IP address

[quote]AT+SETTIME=10/09/2013,13:11:11
[OK]
AT+DNSLOOKUP=m.google.com
IP:173.194.72.193
[OK]
[/quote]
(4) Connect google HTTPS server (Port : 443) and open a SSL session

[quote]AT+NCTCP=74.125.31.193,443
[CONNECT 0]

[OK]
AT+SSLOPEN=0
[OK]
[/quote]
(5) Get HTTPS data using

[quote][color=#FF0000]{1B}S0GET / HTTP/1.1{0x0d}{0xa}{0x0d}{0xa}{1B}E[/color]

HTTP/1.1 302 Found
Location: google.co.kr/?gws_rd=cr&ei= … lQXBjIGADA
Cache-Control: private
Content-Type: text/html; charset=UTF-8
Set-Cookie: PREF=ID=cd6b84ea92e31f22:FF=0:TM=1378790022:LM=1378790022:S=OVjrgP0A_HmPFcrZ; expires=Thu, 10-Sep-2015 05:13:42 GMT; path=/; domain=.google.com
Set-Cookie: NID=67=b2GN4OS8bTRLVcSUxs2zRJtm1UUP9_E4y-H1W-80Ef5uy0yGF3Lxs3KQGFXdDf-rjle941GgNMA_3UoDqKB5nR_7yI9Hm8dam-lB9xn0Wr6VzKn8PQ72uf-k5E3YoB21; expires=Wed, 12-Mar-2014 05:13:42 GMT; path=/; domain=.google.com; HttpOnly
P3P: CP="This is not a P3P policy! See google.com/support/accounts/ … wer=151657 for more info."
Date: Tue, 10 Sep 2013 05:13:42 GMT
Server: gws
Content-Length: 262
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Alternate-Protocol: 443:quic

302 Moved

302 Moved

The document has moved here. [/quote] (6) Close TCP Connection [quote]AT+NCLOSEALL [OK] [/quote]

#6

Hello ssekim,

I tried your steps but i have this error

ATI2
WizFi210
1.1.0.5(W)
[OK]
AT+NSTAT=?
MAC=xxxxx
WSTATE=CONNECTED     MODE=AP 
BSSID=xxxxx   SSID="xxxxxx" CHANNEL=11   SECURITY=WPA2-PERSONAL RSSI=-49
IP addr=192.168.1.11   SubNet=255.255.255.0 Gateway=192.168.1.1 DNS1=192.168.1.1 DNS2=0.0.0.0
RxCount=68 TxCount=65848
[OK]
AT+SETTIME=21/01/2014,19:20:44
21:1:2014 19:20:44
AT+DNSLOOKUP=m.google.com
IP:74.125.128.193
[OK]
AT+NCTCP=74.125.128.193,80
[ERROR: INVALID INPUT]

I keep getting the same error, on LAN as well.
Pinging however works fine. Any solutions?


#7

I think that there are some mistyping or something like that in your test.
Generally, “[ERROR: INVALID INPUT]” means wrong-format-parameter as below.

[quote]at+nctcp=4.4.4.4,77
[ERROR]
at+nctcp=4.4.4.4,
[ERROR: INVALID INPUT]
[/quote]


#8

I keep getting spam report issue, and do not let me reply.

I was wondering if this is common on the firmware. Since only this command has ‘INVALID INPUT’

I tried with different software terminals and parameters, all other commands work fine. Any other solution for this issue?


#9

What is your F/W version?

How about try it again with latest F/W version?

You can download that in the below link.
http://wizwiki.net/wiki/doku.php?id=products:wizfi250:wizfi250firmware:start