WizFi 630 - Can't connect to other Wifi using Serial-Command


#1

Because of your Suggest in your QnA-Answer to use this Forum, i transfer my Issue to this Thread.:

Hello!

All commands used so far (except the “GF”-Command) work correctly.
And as I tried to mention:
The “GF”-Command correctly adds a specific Profile, but doesn’t activate it. …It doesn’t log in to the Wifi which is specified by the Profle.

Kind regards,
Christian Grunbacher

[quote]
Dear customer.
Thanks for your interest in WizFi630.

Please, confirm all command doesn’t work or specific command you said doesn’t work.

P.S. : We open WIZwiki forum.
index.php
We take care of it a lot.
So, use it a lot, please.

Thanks.
WIZnet.

[quote]
Hello!
I need to configure my WizFi630 through the Serial-Command-Interface and stumbled over following Problem:
When Using the Wizfi630 in Client(Station)-Mode, i can’t connect to another Wifi.
-> The Command “GI” can’t be used, because the target-AP broadcasts a WPA-PSK-Network and no WEP
-> The Command “GU” (although it is suggested in the manual) can’t be used in client(station)-Mode.
-> So my only chance to connect is by creating a Profile using the “GF” command.
-> Creating a Profile with the correct settings works, but the WiZi630 doesn’t connect to it…
-> …unless i go to the Web-Interface log in and click on the “Profile” section. (nothing else)
…But i in my Application i have to connect to a Wifi by using serial-commands and no Web-Interface-Inputs.

I would be very thankful if you could help me with this problem!
[/quote][/quote]


#2

In the meantime, i discovered following (ugly) workaround:
Sending the Command restarts the WizFi and after that, it connects to the WiFi which i have configured previously with the <GF1…> Command.

But… this leads me to the next Problem:
I Cannot delete Profiles using the <GF0…> Command. -> I always get the Error <2> (“Command Parameter is mismatch”).
(And yes, i sticked to the given Example in the Manual which says to use the Set-Profile Command like <GF0_test-ssid_0_3_1_1_12345> …but of course with the correct parameters after “<GF0_” )

So my application can only connect to max. 2 WiFi’s (or 1 if WizFi doesn’t check both configured profiles on startup)!
And afterwards i would have to restore Factory-Defaults and reconfigure all settings again… :frowning:

(((which leads to the next problem: The Serial-Command-Interface doesn’t provide Commands to configure any Firewall-Settings :cry: )))


#3

Dear customer
Thanks for your interest in WizFi630.

If you want to delete profile using command, you have to use command parameter like <GF0_SSID>.
If enter <GF0_SSID> correctly, WizFi630 will return message.

Thanks
WIZnet


#4

Dear Support,

thank you for your answer!

This solved my Problem, regarding the deletion of Profiles.
(Maybe you should correct this Command in the Serial-Command-Guide located at:
wiznet.co.kr/Admin_Root/UpLo … %201.2.pdf )