WIZnet Developer Forum

Fail flash upgrade

Hello to all of you,
recently we bought the WIZ550web. We tried to upgrade the firmware from 1.0 to 1.1 version but the instructions were not so cler.
First of all , there is no schematic diagram , where is exactly the “BOOT” push button? There are 3 buttons, one on the card with lan and other two on the main board. Anyway we pushed one of these two and we got in BOOT - Program state.
We connected with “eclipse” with serial. It connected.
I tried first , as your instructions, to upload the WIZ550web_Boot.bin in 80000000 address. Not erase, as in your instructions. After i make a reset and got again in “program” mode. I upload the WIZ550web_App.bin in 80006000. After i tried a reset , but nothing happened. The board disappeared at all. MAC, serial is not working. The led are open , but even through serial i can not connect. I get only 2 “00” “00” from UART. Any idea if there is something that i can do?

Friendly
Stratos

Hello,

the BOOT pin is labeled on the WIZ550WEB-EVB.
We recommend upgrading the firmware by using a TFTP server. In case this server is not available and you are not able to install such a server, you can still use the Flash loader of STmicro. Please refer to the instructions on wizwiki.net/wiki/doku.php?id=pro … b_download - also please take care to use the proper addresses for programming the APP and the BIN files.

Reset the device after flashing both files and open a serial console to the UART1. The module will ask for

You should respond with the letter S and the MAC address of your module, for example: S0008DC010203 as one string.

The module will then respond with the following header:

[code]Input MAC ? R
OK

=======================================
WIZnet WIZ550WEB Revision 1.0
Embedded Web Server Module
Firmware Version 1.0.1
=======================================[/code]

Best regards,
Felix

Dear Mr Felix,
We have uploaded the 2 bin , maybe succesfull, in 2 different addresses, as you described.
But, after the last reboot we terminal program that we use , it returnes only two “00”, “00”… Nothing else.
There is NO message "INPUT MAC?"
Now you say to enter the MAC address with an “S”. Where we can find the mac address. Is it written anywhere?
We didn’t keep it, and if it doesn’t ask MAC what shall we do?

Best regards
Stratos

Hello,

If your upload was successful and at the right address, the module would be asking for the MAC address.

Make the board enter the BOOT mode by pressing the BOOT pin and while holding reset the board. It will automatically enter the BOOT mode and you will be able to use a stmflasher to flash the BOOT and the APP file one after another. After both files have been flashed, reset the board by pressing the RESET button or power cycling the operating voltage. In the meanwhile you should open a serial connection to the UART1 and there you should be able to see the input possibility for the MAC address. After entering the MAC address the module is ready to use again.

The MAC address is written on a sticker on the module itself. It starts with 00-08-DC.

Best regards,
Felix

Finally i got lucky. The problem was on the power switch, i changed it and i got normal in “Program mode” and i put the firmware normal and success.

Thank you a lot.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.