WIZnet Developer Forum

SPI not initializing

Hello,

I connect the wizfi250 through USB cable and send the following command through putty : AT+MSP1=2,0 in order to set as communication interface the SPI, I get a response = “OK”

Then if I query the wizfi again with AT+MSP1=?, then I get " AT+MSP1=1,0"

Why the mode changed from “1” to “2” ? Will I be able to use SPI?

Is there an instruction set or datasheet regarding SPI driving of wizfi 250?

Thank you ,

Best Regards,

Andreas Achilleos

Hello Andreas Achilleos.

You can drive the instruction through SPI interface same as UART instruction.

When “AT+MSPI” status is set to “2”, you don’t use SPI interface. Just use UART.
I guess it’s because AT+MSPI status was changed to “0” or WizFi250 is set to Factory default.

Thanks.

Hello Daniel,

[quote]AT+MSPI=,

Meaning: SPI Configuration

: Choice of interface (Required)
If set 0, WizFi250 Will set the interface it received first. For example, If MCU sends UART signal to WizFi250, WizFi250 will be set as UART interface. On the other hand, If MCU send SPI signal to WizFi250, WizFi250 will be set as SPI interface.
Parameter Meaning
0 Auto(Default)
1 UART
2 SPI [/quote]

You said : [quote]When “AT+MSPI” status is set to “2”, you don’t use SPI interface. Just use UART[/quote]

What is the correct for SPI? AT+MSPI=1 OR AT+MSPI=2 ?

Thank you,

Best Regards

Andreas Achilleos

Hi Andreas Achilleos

It was my mistake. AT+MSPI=2 is the correct command for SPI interface.

Official document is the most accurate.
wizwiki.net/wiki/doku.php?id=pro … rt#at_mspi

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.