[link-down event], what is best technic?


#1

Dear all,

my application set the wizfi250 as STA mode, connect to an AP and open different TCP and UDP sockets.
all works great.

from time to time, the wizfi250 module send some [Link-Down Event].
actually, my application reboot the module in this case.

is it the best method ?
or did i simply try to restart the socket down ?

thanks, regards
Phil


#2

Hi,

Are you using the AT+FSOCK=8 command?
When AT+FSOCK=8 option is set, WizFi250 will reboot after link down event itself.

For example.

[quote]at+fsock=?
5000,5000,5,100,0,0,0,0
[OK]
at+fsock=8,1000
[OK]
at+fsock=?
5000,5000,5,100,0,0,0,1000
[OK][/quote]

So, If you want to disable the Socket function about reboot.
Try at command like below.

[quote]at+fsock=?
5000,5000,5,100,0,0,0,1000
[OK]
at+fsock=8,0
[OK]
at+fsock=?
5000,5000,5,100,0,0,0,0
[OK][/quote]

wizwiki.net/wiki/doku.php?id=pro … t#at_fsock

I think it is the best way to reopen the socket among the function of the WizFi250 when there is no socket connected.


#3

i do not at all use AT+FSOCK .

why AT+FSOCK=8, 5 (5 by example) will be better that a hardware reset module ?
more faster ??
if a link is down, is there any chance it will back up during the 5 seconds ?

thanks, regards


#4

well i do some tests :
i set AT+FSOCK=8,5

it seem that yes, after the [link-down event] occurs, there is some [link-up]
so i don’t reset anymore the module.
all seem working, but not !

before any [link-down , yes my browser can access to my wizfi250module
but after, the browser can’t anymore !.. i need to hard reset my board …

did i miss something please ?

thanks


#5

Hi,

If FSOCK=8,5 was set, WizFi250 can check the link status every 5 seconds.

And the profile(AT+MPROF=S) must be saved after AT+FSOCK.


#6

Wizdaniel,

what i say is that if i enable the feature, after a [link-down event], the web browsers can’t access anymore to the modules !
even if the [link-up event] occur right, the module seem not communicate anymore !

regards


#7

Hello Team,

does the “AT+FSOCK=6,10” command has any influence when the WIZFI work as TCP server (AT+SCON=O,TCN,192.1…) ?

thanks, regards


#8

Hi,

First, when it works as a TCP server, the TCP server is TSN, not a TCN (like this AT+SCON=O,TSN,5000,0).
We assume that it works as TCP server, AT+FSOCK command is not influence that.
When it is TCP client, AT+FSOCK command operates.

Thank you.

Best regards.


#9

Hello

well back with this question then … what is the best technic to manage a link-down event when the Wizfi250 work as TCP server ?

did i reboot the module ?
did i try to re open the socket ?

fw 1.0.5.2

thanks


#10

Hello

please may we know exactly what is the Link-Down event mean ?
i notice a lot of this event without any reason from my side.
the AP is 2 or 3 meters of the module, with good antenna.

and again … what is the best thing to do when we receive this event ?
sometime, the link up arrive “immediately” then i just check if the TCP server is running gain.
but some time the TCP server is not running anymore and the only solution is to reboot the module. which is not really “user friendly” … the web browser of the user may can’t access anymore the the TCP server !

thanks


#11

Hello Team

please, may i get answer on this question ?
the “link-down event” occur several time without visible reasons.

only the TCP server is running on the module and waiting some client request.
even when no client connected, just waiting, i notice this event.
again, the AP is just 3 meters from the module. the RSSI is perfect.

i’m using the 9.0.5.3 firmware, but it’s same with 1.0.5.2 !

1/ what can be the reasons of this event ?
2/ what is the best method to manage this event ? as i say, sometime the TCP server stay open, but some others, i need to reboot the module.

thanks, regards