WIZnet Developer Forum

Migrate from Wiz610wi to WizFi220

Hi,

We have been using the wiz610wi module for one of our devices and now that it is obsolete, we purchased the WizFi220 EVB to try to duplicate the same functionality.

Our environment is as follows:

In the Wiz610wi we create a TCP server using the port 5000 and then we connect to the socket in the iPAD and we were using the escape character 0x00 in order to tell the module when the package of data we went to send is completed.

I have tried to duplicate the setup using the WizFi 220 but unfortunately it doesn’t work.

The commands I have used are the following:

AT+WM=2
AT+WAUTH=0
AT+NDHCP=0
AT+NSET=192.168.1.254,255.255.255.0,192.168.1.254
AT+DHCPSRVR=1
AT+WA=LimitedAP,8,
AT+NAUTO=1,1,5000
ATA2

After this I can connect to the WIFI network in the iPAD and I get the right IP address etc. However when it tries to open the socket it gives an error.

I cannot ping the iPad from the module either.

Could you please give some guidance on how to achieve hits?

Regards,

Hi

I have tried to use the command that you typed.
And i faced with error like your case.

The problem is AT+NSET command.

A WizFi220 gives the IP to a client using DHCP when DHCPSRVR is set.
When a WizFi220 gives the IP, a WizFi220 gives WizFi220 IP + 1.

If you set the WizFi220 IP = 192.168.1.254 and DHCP Server enable.
Client get the IP = 192.168.1.255 using WizFi220 DHCP Server.
192.168.1.255 IP is a Broadcast IP. WizFi220 Socket gives you an error.

so, you have to change the WizFi220 IP except ~. 254,~. 255.

Hi Wizdaniel,

You were right. I fixed the issue just changing the IP to .1 before executing the DHCPSRVR command and the change it back to .254 after and it works!.

–Edit–

I found the issue. Nothing to do with the WizFi220 module.
My apologies.

Regards,

Hi cellix

I’m glad to hear that you fixed the issue.

I wish you success with your great application.

Thanks.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.