WIZnet Developer Forum

Wiz108sr 통신 관련 문의

WIZ108SR을 이용하여 Client에 물려서 해당서버와 통신을 진행하고 있습니다.
아래 그림과 같이 구성중입니다.


두대의 서버로 각각 데이터통신을 해야하는데, Client에 PC를 물려서 통신을 하면 정상적으로 통신이 되는데,
WIZ108SR을 물려서 통신을 하게되면 그림과 같이 하나의 Server에서는 데이터수신이 불가하다고 합니다.

검토하시고 도움 부탁드립니다.

안녕하세요.

일단 유추해보았습니다.

WIZ108SR을 사용하고 KT ADSL은 정상적으로 된다는 것은 일단 WIZ108SR에서 LTE Router로 가는 무선 신호는 정상적으로 보내진 다는 것으로 생각됩니다.

그런데 T-board 광랜에서는 데이터 수신불가인데,

이 부분에서 T-Board 광랜쪽으로 무선이 안받아지는 것인지 아니면 광랜을 거쳐 다른 Router를 거치는데 그쪽에서 안되는 것인지 정확한 확인이 필요합니다.

어떤 문제때문에 LTE Router의 무선 값이 변경되어 T-broard에서 Packet을 버릴 수도 있는 상황이 있을 수도 있고, T-broad에서 packet은 받았지만,

이 후 다른 문제때문에 전송이 안될 수도 있기 때문에 이 부분 확인 부탁드립니다.

감사합니다.

그림이 잘못된것 같아서 다시 문의드립니다.



보시는것과 같이 WIZ108SR을 사용하지 않고 PC를 Client로 사용해서 보낼 경우에는 Server가 여러군데여도 정상적으로 데이터를 수신합니다.

하지만, WIZ108SR을 사용할 경우 Server 한군데로만 정상적으로 수신이 된다고 합니다.

다시 검토 부탁드립니다.

안녕하세요.

추가 질문 드립니다.

WIZ108SR을 어떤 상태로 통신하고 있는지에 대해 설명 부탁드립니다.

UDP를 이용하여 통신하는 상태인지 설정은 어떻게 하였는지 통신 방법은 어떤 방법을 이용하였는지에 대한 자세한 설명 부탁드립니다.

감사합니다.

아래와 같이 설정하였습니다.
동일 설정에서 Server 쪽 KT ADSL (약 10~20 MB) 라인에서는 데이터가 들어오고
T-Broad 광랜 (Full 100 MB)라인으로는 데이터가 들어오지 않습니다.

아래는 WIZ108SR 모듈의 설정한 내용입니다.


검토하시고 회신 부탁드립니다.

안녕하세요.

그림 화질이 좋지 않아서 잘 보이진 않는데요.

그림상 TCP client로 되어 있는데요.

그렇다면 TCP 연결을 이용하여 KT ADSL(Server)와 연결 시 데이터 통신이 되며,

T-broard 광랜(server) 측으로 데이터 통신시 데이터가 들어오지 않는다는 것이죠?

그러면 TCP로 통신을 하니깐, TCP connection은 되는 것 확인하셨나요??

Serial Option 전부 OFF 한 상태에서 TCP Connection이 정상적으로 되는지 확인바랍니다.

그리고 Connection됐을 시, Serial Terminal로 Data를 밀어넣어서도 통신 되는지 확인 바랍니다.

감사합니다.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.