WizFi250 TCP Server station mode , only one TCP client - new thread

Dear team,

i open this new thread, because previous one seem not anymore updated.

well you let us know that actually only 1 TCP client is possible.
this, because “a bug in the broadcom SDK” …

Please can you share more information about this bug :
wich SDK ?
wich broadcom chipset ?
any link on official broadcom forum where this problem is discuss ?
anything to know if that “bug” is under investigation ? if there is a chance that it will be fixed ?
hard to beleive that everybody who use this chipset, don’t claim over it !

thanks, i expect a clear Wiznet position about this problem. do you have any action about it ?
maybe i’m wrong, but i don’t see anywhere in your documents/web site this big limitation !

thanks, regards


That’s not a chipset’s bug.
It’s a kind of decision of WIZnet about TCP server.

Broadcom chip have not much memory, so maximum TCP connection of WizFi250 is limited.

And to support multiple TCP client, TCP-listen-socket should not closed after a TCP client connection as below

Multiple TCP Client
AT+SCON=O,TSN,… ===> 1 Socket is using (Listen Socket)
(a TCP Clent connected)
[CONNECT 0] ===> 2 Sockets are using (TCP connection socket, Listen Socket)

Single TCP Client
AT+SCON=O,TSN,… ===> 1 Socket is using (Listen Socket)
(a TCP Clent connected)
[CONNECT 0] ===> 1 Sockets are using (TCP connection socket)

Because WIZnet think that <spending 2 sockets in TCP server mode> is a waste, WIZnet decided to support a single connection in TCP server mode.

If you need TCP multiple connection, how about the below?

WizFi250 : Listening 4 ports

TCP Client : Trying to connect multiple port 2001 ~2004

1st TCP client try to connect to port 2001 and succeeded it.
2nd TCP client try to connect to port 2001 and failed it.
Then 2nd TCP client try to connect to port 2002 and succeeded it.

BR, Steve

Dear Steve,

==> that’s not what Wizdaniel say in the end of the previous thread …!

so the specific version that you speak about in previous thread (by ssekim » Mon Jun 02, 2014 2:46 am ) is not bugged and available ?

==> i know this 8 sockets limitation !.. i don’t need 8 sockets, but need more than 1 client on the same TCP socket server !

==> please allow users choice !
or it’s a WIZnet decision to force us to buy more expensive module ?
anyway, it’s not clearly define in the “feature list” of the WIZFI250 module

==> again, users choice is better !.. and it’s what we need (me and others users in this forum !)

as already answered in previous thread, multiple ports for “multiple client” is not a solution for our application !

after complain from our customers on the first prototype batch, we need to solve this issue.
i need to know if we can expect a better and fast cooperation with WIZnet or not ?
i don’t speak about 1 or 2 modules … but several more ! …

thanks, waiting your reply


I’m sorry to have kept you waiting so long.

From now, multiple connection is available WizFi250.

I’m going to send newly unofficial F/W( to registered e-mail address.

But, you have to learn how to use this method and remind yourself this F/W( is unofficial.

  1. Multiple connection is only possible in “STATION MODE”.

  2. Only One socket(not connected) can exist.
    If you want to open same port, you must wait until the previous socket connection.




Number of Sockets : 3 (SCID/Mode/Remote/Local/DataMode)

He asked me via e-mail.

Q: Is there any incompatibility with FW ?
=> Compatible with FW
=> Firmware is being updated. So some commands added in this FW version. But, you don’t need to worry about that. All commands that you know are compatible with previous FW.

Q: Is there any new commands/answer I need to implement for multi TCP client ?
=> For use multi connection feature, you have to use the same command like FW1.0.4.2.

=> Refer to the following steps.
   1.	After Wi-Fi association.(AT+WSET, AT+WSEC, AT+WNET, AT+WJOIN)
   2.	Use the “AT+SCON=O,TSN,,,5000(port),0” for TCP Server open. (this condition is “Listen”)

3. you should wait until socket connect to peer….

4. After the socket connection, you have to open another socket as same port(5000)

Q: Is this version ( come from 1.0 4.2 release ?
=> Yes.

Q: Is this “update” will become official in the future ? I mean, if you update the to xxxx , I will lose this feature ?
=> There is no problem.
=> many firmware versions are unofficially updated ( to now, most newly version is
=> In the future, if we should officially release the firmware. We could release the firmware or above

Q: The comment that you not understood.
=> In order to open the socket as multiple same port, you must wait the previous socket connection(yellow line of number 4 in steps)

 => If you want to open the [socket 1] as port 5000 when [socket 0] as port 5000 already was opened.
 => You can open the [socket 1] as same port after [connect 0] replay

thanks you team, will try it asap

best regards and merry Christmas to all

Hello Daniel,

well i successful update one of our board/module to

i try different things, but unfortunately don’t understand/find a way to allow multiple connections on same TCP server.
i launch the first socket by “AT+SCON=O,TSN,80,0”
the module reply correctly with “[LISTEN 0]”

then i run the webbrowser (FireFox) , access to the module : the web page appear correctly.
i open another webbrowser (Chrome) without close the first one and don’t see anything from the module (i spy the UART lines) : the webbrowser failed after a timeout ( Chrome : ERR_CONNECTION_TIMED_OUT) .

maybe a useful new command may be used : one to inform the wizfi250 module, how many client we allow on the TCP server …?
by example, if we set to “2”, the wizfi250 module will reserve 2 sockets for the server.
then if we try next to open an UDP socket, the module will open it on socket “3”

does it make sens ?

thanks, regards



[CONNECT 0] << you can find this reply when you access to the module(in your case FireFox)

<<<<<<<<<<<<< if you try to access to the module one more time(in your case Chrome), web browser can’t connect to the module.

AT+SCON=O,TSN,80,0 << you have to open the socket one more time(same port number(80))
[LISTEN 1] << this moment, web browser (Chrome) can connect to the module.


So, you have to check the socket status, then you have to open the new socket(same port) when all sockets are connected.


well thanks, will have a try later.

anyway, my suggestion to make a new AT command seem interesting !

wishes best for this new year.
best regards;

Dear Team,

I just made new tests.
this method seems really complicated and inappropriate!
this will hugely break things on our code.

why the module can not support a simpler method, with a new AT command?
the WIZFI210 seems to provide these commands : AT + NSTCP …?

thanks, regards


WizFi210 used different with WizFi250 chip and stack.
This method is our best option.
As you know, the method you want will cause hugely break things on our code.


so what is the solution ?
give up the WIZFIN250 module if we need multiple TCP client on same port ?

the fact that 1.0.5 version is unofficial is a problem. we can’t allow users to update the firmware in the future, because we don’t have any guarantee about this function.
the actual “method” to manage this patch seem really not friendly.

we are really disappointed to discover this problem too late in our development. the module was pretty good but without this feature, we can’t continue to design with it. too bad !

hope that Wiznet management will change his mind and decide to support officially this important feature.
we can’t simply migrate on your others modules. too expensive and too big.