WIZnet Developer Forum

W7500에 cmsis-dap 으로 펌웨어 업로드 시 오동작(reset반복)문제

타겟보드 W7500보드에 cmsis-dap tool을 이용하여 펌웨어 다운로드 시 무한 반복으로

reset이 걸리는 현상이 발생하였습니다. 특정 펌웨어 업로드 후에 이러한 현상이 발생하였습니다.

cmsis-dap tool은 lpc11u35집을 사용하였고 cmis-dap 펌웨어는 귀사에서 제공하는 lpc11u35_w7500x_if_v1_0_v1_1_150602.bin 파일입니다.

아주 간단한 펌웨어 업로드 시에는 정상적으로 업로드가 가능하나, 특정(코드가 복잡한) 펌웨어를 업로드 후에 다시 업로드 할경우

반복적으로 reset이 발생하여 업로드가 불가능해집니다.

위와같은 오동작 관련해 해결책및 도움을 요청합니다.

안녕하세요.

위 문제에 대해서 몇가지 질문과 자료를 요청드립니다.

  1. W7500칩과 CMSIS-DAP 칩을 사용하여 자체 회로 설계를 하신건가요??
  2. 회로 설계 및 PCB도 자체적으로 제작하신거죠?
  3. 처음에는 동작이 잘되다가 갑자기 이런 증상이 나타난건가요??

위 질문에 대해 답변 부탁드립니다.

그리고 회로 및 PCB Artwork 파일을(Gerber) 요청드립니다.

만약 공개되는걸 원치 않으신다면, 따로 메일로 보내주시면 될 것 같습니다.

감사합니다.

요청하신 질문 답변입니다.

  1. W7500칩과 CMSIS-DAP 칩을 사용하여 자체 회로 설계를 하신건가요??
    wizwiki-w7500 보드 , 그리고 IBDAP 보드에서도 동일한증상이 나타납니다. IBDAP펌워어는 위즈넷에서 제공하는 DAP펌워어 올려서 사용했습니다.

  2. 회로 설계 및 PCB도 자체적으로 제작하신거죠?
    wizwiki-w7500보드에서도 동일한 증상이 나타납니다.

  3. 처음에는 동작이 잘되다가 갑자기 이런 증상이 나타난건가요??
    아주간단한 베이직한 프로그램(LED ON/OFF)을 올리면 업로드 잘됩니다. 하지만 복잡하고 크기가 큰 펌워어를 올리면 처음 한번 업로드되고
    그다음부터는 계속적으로 RESET이 걸려 펌워어 업로드를 할수없습니다.

그리고 회로 및 PCB Artwork 파일을(Gerber) 요청드립니다.
=> 귀사의 wizwiki-w7500 보드에서 동일한 증상이 나타나니 wizwiki-w7500를 참고하세요.

안녕하세요.

어떤 코드를 업로드해서 구성하셨는지 코드 확인도 필요합니다.

그저 복잡하고 크기가 큰 펌웨어를 올리셨다고 RESET이 걸린다고 보기엔 다소 문제가 있을 수 있습니다.

wizwiki-w7500보드에서도 동일한 증상이 나타나신다는 점은 코드의 문제일 수도 있으며, 정확한 판단을 위해서는 제작하신 자료를 지원해주셔야 합니다.

그렇지 않고선 문제 해결에 도움드리기는 어렵습니다.

저희 측에서는 정확한 문제판단이 어렵기 때문입니다.

감사합니다.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.