WIZnet Developer Forum

Power On problem

Continue my experience with W7500.
There’s a problem with Power On. Sometimes my application won’t start after switching power on. It is necessary to press Reset. Also the time of the Reset is important. We’ve made our own PCB and the problem remains. Is there some sequence of the Resets to W7500 and IP101GA?
Thank you.

Hi.

I’m sorry about your problem…

I think you have W7500 chip is revision ago.

We will plan w7500 chip revision.

This problem is need to Supervisor IC.

refer to below document.

W7500_revision_information_v2.pdf (395 KB)

And refer to below link. It is W7500P overview and Reference schematic.

wizwiki.net/wiki/doku.php?id=pro … 500p:start

Thank you

Hi, Edward
Thank you for your quick response.
Are there any differences while using this chip in W7500+IP101GA system?
Is it possible to use it instead on internal watchdog to solve my previous problem with reset from internal watchdog:

Thank you.

Hi.

It is different. you said watchdog is software function.

And I said watchdog is hardware reset function.

W7500 was found do not reset.

So, add external watchdog IC. so If W7500 does not reset, external watchdog is reset active.

Thank you

Continue my experience with W7500.
I’ve successfully solved previous problem with external watchdog and made new PCB.
Another problem:
My device is working OK with chip W7500 A644298 1511.
If I solder chip W7500 A7220022 1639 strange effect occurs:

  • it works OK until first external Reset
  • if I press Reset just after uploading firmware, it restarts correctly
  • if I press Reset later everything is OK, except external SRAM and EEPROM - device is not able to communicate to them.
  • I must power off device and wait for some time.
    Chips 23lcv1024 and 25aa02e48 are connected to PA_05…PA_08 and PA_11.
    I’ve replaced almost all other chips on PCB and only the replacement of W7500 had effect.
    Beside that, sometimes device stops functioning at all and it is necessary to rewrite firmware.

Can you help me?

The problem remains.
I’ve soldered 2 identical PCB. The only difference is W7500 chips.
PCB with chip A7220022 1639 refuses to work with external SRAM after reset.
Waiting for any help.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.