WIZnet Developer Forum

WIZ107SR-TTL not recognized by configuration tool

Hi, I am trying to setup my Wiz107SR-TTL adapter, however, the configuration tool will not recognize that it is plugged in.
I have the adapter powered via 3.3v, and connected with an RJ45 Ethernet cable. Is there something I’m missing? The red led is lit when powered.
The lights on the rj 45 mag jack are not turning on either. I have tried powering the active low pins (nReset, HW_Trig), but it still wont link. Also, I have turned off windows firewall.

The product number on the board reads WIZ107sr and does not have the -TTL included, is this normal?

Thanks!

Update:
I was powering the board using the usb port on my laptop and a voltage divider (from 5 to 3.3 volts). USB ports are capable of supplying 500mA and this board required 250mA. So I thought I was safe - but when I used a variable power supply it started working. Anyone know why that is?

Thanks!

I might be able to provide some insight :slight_smile: (just another customer though)

I find that the module doesn’t boot-up when the voltage/current combination is, eh, shall we say… not correct. Skinny wires providing 3.3v will drop to an unsuitable low voltage when the module tries drawing current to operate. The WIZ107SR* takes quite a bit of current, compared to usual chips that consume practically nothing. This is evident by the chip heating up when it’s running. When I used some skinny wires to power it from a 3.3v LiFePO4 cell, it did that same thing - LED on board lights up, but Ethernet won’t come up. Connected with beefier wires and it worked OK. Adding a capacitor could help as well, to smooth out the power.

In general, with 3.3v supply, it’s better to have thicker wires (22 AWG is what I use for a 6" run to the supply).

As for the config tool, it’s also worth mentioning (but probably unrelated here) that I’ve had issues running the WIZ107SR tool in Windows 10 - it doesn’t detect any modules, even with firewall disabled and everything. Run it on Windows 7 or XP and it works OK.

Finally, as for the “TTL” phrase, that’s simply a BOM (bill of materials) modification to the module. On the TTL version, notice a lot of missing parts on the bottom of the board. The chip itself seems to output TTL-level serial, but the board uses transceiver chips to convert it to RS232 or RS485. In the TTL version, it’s just passed straight through to the chip, no converters needed. So, since parts are the only thing changed, the board silkscreen stays the same. :slight_smile:

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.