WIZnet Developer Forum

W5500 board - FDX Led steady on - sending data, not receiving

Hi,
I am having issue with new PCB designed around Arduino 328-W5500 chip, which is driving me crazy…
New board is designed on same W5500 schematic (in attachment) as previous one, same components used, but this one doesn’t work…
When lan cable is connected to board, Link is up, link led have steady yellow light but FDX led also lights steady!

Pc cannot ping W5500 chip - no reply but on the other side, chip is sending UDP data to network. Arduino based chip seems to be working fine, output from serial monitor is showing that w5500 is set to correct IP address.

Arduino code that is used to send data to network over UDP is working, I am able to send correct data from Arduino>W5500 to network.
Wireshark is showing source correct IP address of the chip, so I came to conclusion that transmit side from chip is working fine.
Must be something with Receive side of the design

So far I have tried following:

  • Different LAN cables, from 1m-3m, straight and crossover
  • Connection to PC and network switch
  • De-soldered Resistors R14 & R15 from CS and INT bus
  • Removed Ressistors R32 to R36 - according to wiznet, these are used for stability but not included in my previous PCB design
  • Removed AtMega 328 from PCB to avoid issue on MISO/Mosi buses
  • Disconnected pin 2-RCT from RJ45 connector (I am using Bel Stewart SI-60062-F RJ45 connector)

NOthing helped, same result - FDX led is always on

I am planning to make following changes further:

  • Increase capacitance of C10 & C11 capacitors from 6.8nF to 10nF (used in some designs)
  • Reduce value of damping resistors R12-R17 from 33ohm to 0ohm

Any other suggestions are welcome

Only difference in W5500 is that these are produced in 2016, old PCB had ones produced in 2014.
Possible that these chips are different?

Thank you in advance for any info
Regards,


Hi.

I think… Don’t care.

important point is LINK led.

because, LINK is PHY(hardware) link indicate LED.

ACT(FDX) is data TX/RX indicate LED.

Thank you

Hi,
Communication doesn’t work, that is the issue
I am not concerned about led at all…

Which MAC address is used for the W5500 chip?

HI,
I’ve been using address range from WizNet chips configured in Atmega328 chip- 00:08:DC:xx:xx:xx
I am assigning that address from Arduino code

I dont know how to read actual MAC address of W5500 chip

Still dont think that issue is with Atmega/Arduino side since W5500 behaves the same even with Atmega removed from board

I found mistake in my design but it does not solve my problem
Can some of experienced guys help here?

Still don’t understand how previous design worked…

Pinout of Bel Fuse RJ45 connector states that pins 1&2 are TX
I have connected it to pins 5&6 of W5500, which is actually receive.
It means that I have two capacitors 6,8nF on TX line, connector pins 1&2

But I have removed RJ45 connector and connected it with wires in proper way, still same behavior
going crazy…


I don’t find schematic mistaken part.

Are you making PCB ?

If you making PCB, You need checking artwork.

refer to below 2 schematic & Artwork file.

  1. WIZ550SR-EVB

wizwiki.net/wiki/doku.php?id=pro … 50sr_ds_kr

  1. WizArduino

wizwiki.net/wiki/doku.php?id=osh … uino:start

Thank you

Thanks for advice
I did designed board myself so this could be a reason why it is not working.

Now I am making new design so your opinions are welcome

I have routed RX and TX lines to W5500, keeping in mind distance from power lines and each other
Total length of the traces is almost the same (0,5mm difference)

Any comments to it?
Thank you in advance

Hi.

Are you using RJ-45 inside transformer ?

If using RJ-45 inside transformer, It is not pave cooper in pin environs.

And you need more wide gnd line on ethernet environs pin.

Thank you

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.