궁금한게있습니다


#1

첨부파일을 확인하시면

제어기(W5300)을 이용하여 공유기에 접속하여 PC 1,2,3과 통신이 잘되고 서로간에 데이터가 왔다갔다합니다.

IP는 고정IP입니다.

그런데 무선으로 공유기에 접속된 PC4번에서는 제어기에 Ping도 안나가고 데이터를 주고 받지를 못합니다.

Pc들 간에는 통신이 잘되고요.

그리고 Iptime 공유기에서 제어기에 설정한 고정ip번호를 인식하지 못합니다.

해결방안을 부탁드리겠습니다.

W5300베이스 소스는 wiznet16bit 소스를 이용하여 작성하였습니다.

감사합니다.



#2

안녕하세요 고객님.

먼저 W5300의 설정값들이 어떻게 되어있는지 레지스터를 읽어서 확인 후 알려주셨으면 합니다.(MAC, IP, subnet 등등)

그리고 공유기의 동작모드가 bridge 인지 NAT인지 확인 부탁드립니다.

그리고 만약 공유기가 IP를 인식 못한다면 통신이 불가능 할 텐데 질문하신 공유기가 고정 IP의 번호를 인식 못한다는 의미를

좀 더 자세하게 설명 부탁드립니다.

감사합니다.


#3

첨부파일은 레지서터에서 읽은 내용과
iptime에서 읽은 내용입니다. iptime에서는 제어기 ip번호인110번을 제외하고는 다 보이며

첨부퍼일 2.jpg는 레지스터에서 읽은 내용입니다.

감사합니다.

그리고 공유기는 NAT입니다.




#4

안녕하세요 고객님.

설정은 문제 없어 보입니다.

공유기에서 제어기의 IP주소가 보이지 않은 이유는 고정 IP를 할당 하였는데 데이터를 한번도 주고 받지 않았을 경우 그럴 수 있습니다. 아마도 이 이유때문인 것 같습니다.

혹시 공유기의 WAN port로 인터넷이 연결 되어 있는지 확인 부탁 드리며, 유선으로 연결된 PC에서 wireshark 같은 프로그램으로 제어기와 주고 받는 패킷을 캡쳐 해서 올려 주셨으면 합니다.

저희 제품은 펌웨어와 상관없이 link가 연결만 되있으면 자동으로 ping reply를 보내기 때문에 PC4에서 보낸 핑 패킷이 제어기로 도착하지 못한 것으로 판단 됩니다. 이는 네트워크 문제로 보여집니다.

감사합니다.


#5

관리자님 말씀대로 셋팅하여 테스트 하였습니다.

유선 200번에서 110번 제어기로 데이터를 주고 받았고 Wan에 연결된 인터넷 선은 제거 하였습니다.

그리고 말씀하신 wireshark로 캡쳐를 저장하였습니다.

파일은 압축파일로 저장하였습니다.

확인 부탁드립니다.
2013_10_29.zip (7.96 KB)


#6

안녕하세요 고객님.

우선 저희 칩은 정상적으로 동작하는 것으로 보입니다.

문제는 공유기로 보입니다. 192.168.0.200 유선연결된 static 으로 IP를 설정한 PC는 공유기에 등록이 되어있는 것으로 봐서는
직접 등록을 해준 것으로 생각 됩니다. 저희가 해당 공유기의 설정 방법이나 동작 내용을 알지 못하지만 제어기를 공유기에 등록해보고 다시한번 테스트 해보시기 바랍니다.

그래도 안된다면, 제어기 와 공유기 사이에 더미 허브를 두어 제어기에서 데이터을 잘 주고 받는지 확인 후 저희 칩의 문제가 아니라면 해당 공유기 회사에 문의 하시는 것이 더 빠를 것으로 보입니다.

감사합니다.