Problem making W7100A-100 equal to W7100A-S2E-100?

Dear support,

we have bought 100 chips W7100A and I followed the steps found at this forum, mainly from here (viewtopic.php?f=17&t=2758 ), but the chip does not respond at all when using ConfigTool.

We would like a support for a step by step firmware loading to make W7100A-100 equal as W7100A-S2E-100 with firmware found at WIZ107SR. Maybe we are jumping few steps.

The procedure executed:

1- Set pin BOOTEN from W7100A to HIGH level. All VDD supply pins in operation, both crystal working properly;
2- Connect W7100A to WizISP (V2.1.1.0) via UART (baud 115200) with flow control;
3- Uploaded file WIZ107SRv4_06.bin with Flash Operation Mode set to Code;
4- Firmware programmed and veryfied OK;
5- Set Flash Operation Mode to Data. The data file loaded here was read and saved to file from WIZ107SR.
6 - Data Memory programmed and verified OK.
7- Set BOOTEN from W7100A to LOW level;
8- In WIZ107SR/WIZ108SR Configuration Tool Ver1.4.4.1, Search for UDP broadcast method.
9- No response despite link and act led are flashing.

We have tested this configuration tool with WIZ107SR module and it works fine, but with the W7100A with firmware uploaded there is no response.

Is there a need to program some specific data in a specific address using WizISP tool? Or copying the data file from WIZ107SR is alerady enough?

Have we jump some steps?

Please let us if it is not possible to program W7100A-100 with the available firmware from WIZ107SR.

We appreciate your help.


you must be WIZ107SRv4_06p.bin file. no WIZ107SRv4_06.bin. It is no include boot code.

refer to below binary. (22.6 KB)

Thank you.

Dear Edward,

Using WIZ107SRv4_06p.bin file it worked. We thank you very much!

After uploaded this file we were able to detect the device via Configuration Tool as well and upload other versions of firmware.

We have tried to change the MAC address using the software WizMACTool(20151127).exe from this post (Problem with Wiz107SR: not found by configuration tool after firmware upgrade - #2 by irina_kim ), but the data file was messed up and the device was not detected in configuration tool anymore.

We used WizISP to reloaded the original data file. But, when detecting the device again with Configuration Toll, it seems to have a problem cause the datafile was messed up again.

So the question have changed. How to modified MAC Address correctly? Should WizMACTool be used or just modify directly from datafile?

We appreciate all the useful help.

Best Regards.



WIZ107SR is no having MAC ADDRESS erase command…

So, It is just use WizISP tool on erase MAC address.

First, WizISP tool excute and com port opening.

second, unlock Data check box in Flash Operation Mode. then lock icon click.

If already unlock Data check box, lock Data check box and lock icon click. then again unlock Data check box, then lock icon click.

third, close com port. and open the WizMACTool. then doing MAC address rewriting.

Thank you