WIZnet Developer Forum

At commands

Hello

I have a few questions :slight_smile:

  1. Can I send AT commands to wizfi250 without having a PC? If yes, in which mode the wizfi has to be set? Ap, station, OTA? UDP, TCP? port number?
  2. Can I control GPIO pins via data mode?
  3. Can I have IF statements? For example : " if GPIO pin 1 = high THEN make GPIO pin 6 LOW"
  4. If the wizfi is running in data mode and there is a communication between android and wizfi+MCU via UART, can the wizfi read the status of GPIO pins and send it through UART to the android or MCU?

Thank you,
Best Regards
Andreas

Hello,

WizFi250 is wifi-module.
So, WizFi250’s role is connect and configure AP.

  1. Can I send AT commands to wizfi250 without having a PC? If yes, in which mode the wizfi has to be set? Ap, station, OTA? UDP, TCP? port number?
    -> I don’t know what is your question exactly.
    But, do you want to know that is possible control from MCU? If it so, yes.

  2. Can I control GPIO pins via data mode?
    -> It also possible, but I think that is related question with MCU.

  3. Can I have IF statements? For example : " if GPIO pin 1 = high THEN make GPIO pin 6 LOW"
    -> Yes, it is possible.

  4. If the wizfi is running in data mode and there is a communication between android and wizfi+MCU via UART, can the wizfi read the status of GPIO pins and send it through UART to the android or MCU?
    -> Yes, it is possible.

Thanks, regards

Hello,

  1. Yes, I need to send AT commands from MCU to the wizfi.

  2. So far I have connected the MCU to wizfi, I receive the message from wizfi “wizfi 250 version 1.0” So it means that they are communicating quite well.

But the problem is when I send data over my phone which is connected to the wizfi I do not get them to MCU nor when I send data from MCU I do not see them on my phone! Maybe wizfi is not running at the UART interface? Is on SPI?

  1. NOW in order to send AT commands to wizfi should I do any other configuration on the wizfi? Should I change the mode that is working?
    Because as far as i know if I send data from MCU to wizfi they just go as data and go through the UART and end up to the peer device such a smart phone. HOW do I send the data as AT commands?

Note: I cannot connect the wizfi to a telnet/serial like putty with my PC, in order to send any other At commands.

Can you help please?

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.