W7100A boot problem


#1

Hi, WizNet.

I use WizIsp to program W7100A and mistakenly tried to program ~64KB of code into 255B data memory. Loading stopped at 17% of progress. Now WizISP can’t establish a connection with W7100A.
I broke a bootloader code? Can I run the chip again?

Regards, setime.


#2

Hi, setime.

Bootloader doesn’t matter with code flash and data memory.

So, that W7100A works fine is correct. So I think there are other problems.

I want to know you use EVB or your own board and if you have another W7100, test same procedure and confirm ISP works fine.

Best regards.


#3

Hi, hjjeon0608. Thank for reply.

Sorry, I didn’t mention that W7100A is mounted on the WIZ107SR module, i use it to implement own application.
Now I am working with another WIZ107SR module and its successful programming as before. But a broken module at the same time does not respond to attempts to establish a connection via COM port.

Regards, setime


#4

Hi, setime.

I tested 107SR with your procedure.

But I don’t have seen problem like yours.

So, I recommend to request RMA.

Best regards.