Source code for WIZ550IO PIC


#1

Is the source code for the PIC on the WIZ550IO board available? The reason is we have successfully developed a product using this module at prototype stage. However after moving to real hardware, without the PIC, we can’t communicate when connected to some switches - most are OK but some don’t. It’s a long shot but I was wondering if the PIC was setting some register that we have missed that only affect certain switches? As far as I can tell we do everything the PIC is doing, setting MAC address etc.


#2

Unfortunately, there is no official W5500 code using PIC.

Does it not work only on a specific vendor’s switch?
When using PIC, did it work on all switches?

And, which MCU did you port from PIC?


#3

We are having trouble with the MOXA P206A switch and one of my colleagues (home) WiFi router; the other switches and routers we have tried to date work fine.

If we connect the WIZ550IO module to our board instead of our on board W5500 then we can connect with any switch (as far as we know). We are using a SAM4E from Atmel/Microchip as our Micro with tried and tested code. We are using different magnets but aside from that I was wondering of the PIC on the WIZ550 was setting a register that we’re missed that somehow only affected certain switches.


#4

I am concerned that you used a different magnet.
Could you give me the data sheet and schematics you used?

Regarding the register of the W5500 chip, you will know best whether it is different.
Did not you implement the PIC code?


#5

We are using Wurth 7499210121A jack + magnetics:

I could PM you the whole schematic if this would help. We have used your example code to setup the W5500 and use the DHCP and DNS library and this works great - until we use our Ethernet hardware with the MOXA switch.


#6

I forgot to mention that our design uses POE. The MOXA switch does power our circuit and we have used it successfully on other POE switches.


#7

When connecting to the above switch and router, does not link?
If so, this is a hardware problem.

If it is a hardware problem, we can help you if you give us the schematic that you said.


#8

We found the problem; the Rx and Tx pull-up resistors instead of 49R9 we fitted 49.9K :slight_smile: