WIZnet Developer Forum

[WIZ550S2E] 펌웨어 업그레이드

안녕하세요.

[WIZ550S2E] 시리얼 통신 모듈을 이용하여 커맨더 모드로 통신을 개발하고 있습니다.
커맨더 모드 사용중 한번에 전송 가능한 데이타 가 1024개 이상 안되는것을 확인하였습니다.

포럼을 검색해본결과 Binary_v1.1.2.zip 로 펌웨어 업그레이드 를 하면 1024개 이상의 데이타를
전송 가능하다는 답변을 보고 펌웨어 업그레이드를 진행 하게되었습니다.

“해당 내용은 NXP 칩의 UART 처리 및 기존 코드의 처리 방식에 의한 현상이었습니다.
버그 수정하여, v1.1.2로 릴리즈 하였으며, Update를 진행하시면 사용 가능하십니다.
아래 링크가 릴리즈 된 페이지입니다.” <-- 지난 답변 일부 캡춰

처음에는 TFTP 서버를 이용하여 업그레이드를 진행 하였으며 업그레이드는 특별한 문제가 없이
진행된듯합니다.

Binary_v1.1.2.zip 안에 있는 WIZ550S2E_App.bin 와 WIZ550S2E.bin 두가지를 업그레이드 하였습니다.

업그레이드 진행후 Configuration Tool 을 이용하여 찾아보면 버젼 표시부분이 업그레이드 전에는
1.0.3 인가 하는 숫자만 나오던것이 Bootloader 1.0.1 으로 바뀌어 나타납니다.

업그레이드 이후 커맨더 모드로 진입이 되지 않습니다. +++ 포함 기타 모든 시리얼 통신이 먹통됨
Configuration Tool 로 모듈을 검색하면 나타 납니다.

업그레이드가 잘못되었나 하고 이번에는 Flash Magic 을 이용하여 업그레이드를 다시 진행 하였습니다.
업그레이드는 정상적으로 진행 되었으며 메모리상에 데이타를 베리파이 해보아도 정상으로 나옵니다.

Flash Magic 을 이용하여 시릴얼 모드로 업그레이드를 진행한것이 정상적으로 되었다는것은
시릴얼 쪽 하드웨어는 문제가 없다는 뜻이 될듯합니다. 그래도 커맨더 모드는 들어가지 않습니다.

그래도 안되어서 이번에는 펌웨어 버젼을 되돌리려고 binary_v1.0.3.zip 안의 내용을 다시 Flash Magic
과 TFTP 서버를 이용한 업그레이드를 여러번 진행 하며 테스터 해보았습니다.
물론 업그레이드는 두가지다 항상 정상으로 진행 되었습니다.

다운 그레이드 진행후 Configuration Tool 을 이용하여 찾아보면 버젼 표시부분이 Bootloader 1.0.1
에서 바뀌지를 않습니다. 제가 테스터 한 하드웨어는 WIZ550S2E Ver1.1 입니다.

이후 다른 버젼의 펌웨어 들을 다운받아서 업그레이드 진행 하여도 변화가 없습니다.

한가지 특이한것은 STATUS1,STATUS2 LED 가 대략 0.5초 정도 간격으로 깜박입니다.

WIZ550S2E Ver1.1 하드웨어 2개를 위와 같은 방법으로 업그레이드 시도 해보았습니다.
두개다 같은 증상이 나타납니다.

무슨 문제인지 소중한 답변 기다리겠습니다.

감사합니다.

안녕하세요.

WIZ550S2E와 EVB를 함께 사용중이신가요??
WIZ550S2E의 nHWTRIG 핀을 ON으로 설정하신 것 같습니다.(Active low)

EVB를 사용 중인 것이 아니시라면, 해당 핀을 high로 설정하여 다시 RESET해보시길 추천드립니다.

감사합니다.

답변 감사합니다.

펌웨어 업그레이드 문제는 해결되었습니다.
nHWTRIG 핀 문제가 아니고 TFTP 서버로
업그레이드 하는 과정에서 문제가 발생한것 같습니다.
잘못 업그레이드 된 제품은 Configuration Tool 을 이용하여
검색보면 버젼 표시부분이 Bootloader 1.0.1 로 표시되며

여러가지 버젼의 펌웨어를 새로 다운로드 하여보아도
위의 상태에서 변화가 없으며 정상적으로 복구가 되지 않습니다.
다운로드 방법은 TFTP 서버, Flash Magic 등 다 사용해 보아도
버젼표시부가 Bootloader 1.0.1 로된것은 정상적으로
복구 할수가 없습니다.

복구 불능 제품은 추후 WIZnet 으로 반송하여
원인을 확인 하려고 합니다.

하여 새로이 제품을 구매하여 Flash Magic 을 이용하여
Binary_v1.1.2.zip 안에 있는 WIZ550S2E_App.hex파일을
다운로드 하여 업그레이드 문제는 현재 해결되었습니다.

업그레이드 이후 v1.1.2 에서 새로운 문제를 발견 하였습니다.
그 내용은 새로올린 글 제목
" [WIZ550S2E] V1.1.2 업그레이드 후 AT COMMAND MODE 문제점"

확인후 조언 부탁드립니다.
감사합니다.

안녕하세요.

말씀하신 현재 문제점 확인해보고 연락드리도록 하겠습니다.

감사합니다.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.