WIZnet Developer Forum

WIZ110SR initial configuration

Hello WIZnet team,

I’m using a WIZ110SR to connect a Keithley 2430 DMM’s serial port to an Ethernet LAN. The Ethernet cable is plugged in and I see green and yellow lights. But I cannot detect the WIZ110SR or find its IP address. Are there any initial steps needed for the WIZ110SR to get an IP address via DHCP?

  • I have tried looking for the WIZ110SR in my router’s client list, an ARP scan, and the WIZ110SR configuration tool. All show no trace of the board or any possible IP address.
  • The LAN & router are known working and I can communicate to other devices on the LAN.
  • I have also tried plugging the WIZ directly into a PC via Ethernet and running the configuration tool. Again, no board is detected.
  • Removing the WIZ from the Keithley does not fix the problem.
  • Restarting the router, WIZ, and Keithley does not the problem.
  • If the Keithley is restarted with the WIZ110SR plugged in and powered on, it keeps reporting “ERROR CODE -101”. This error indicates that invalid characters are being received via the serial port.
  • If the WIZ110SR is restarted while plugged into the Keithley, the Keithley reports “ERROR CODE -113” which indicates an undefined header.

Blank config tool result:
wiz110sr config tool

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.