WIZnet Developer Forum

WIZ850io module SPI communication problem.

I’m trying to use WIZ850io module in raspberry pi zero/w.
I double checked hardware wiring and SPI digital pulse using my oscilloscope.
And I figured out the module send constantly 0x01 at every command that I sent.
Is there anyone who suffered this problem?
Following site is the reference instructions.


This post may help you understand what is going on. W5500 responds with 0x01 when it finishes first byte of the command, and expects second byte. In your case it seems telling you that 0x01 “I just have got first byte”, and never comes to second command’s byte.

The picture you attached is not clear what is going to CS. If you deactivate it after first byte, of course command will restart.

Thank you, Eugeny,
I solved this problem yesterday by changing the wiring of wiz850io and rpi 0/w.
But I don’t know what the problem was, yet.
Today, I’m going to test again with your answer and I’ll reply to you if I find the exact problem.
Thank you again.

I think I found some reason.
I connected CSEn pin in WIZ850io to CE0 pin in RPi.
But the CE0/1 lines are controlled by the kernel driver(with wiringPi library) not my code.
So, I couldn’t control the pin properly .
I think this is the reason why the test program worked when I changed the pin wiring.

1 Like

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.