WIZnet Developer Forum

WizFi250 Timeout Settings

Hello,

our company uses the WizFi250 module with the official
FW version/HW version
1.0.3.3/WizFi250 Rev 1.0

We use the "SOCKET Extension Option"
FSOCK=6,0 (no auto-reconnect) when connecting as “TCP Client Normal” with command
AT+SCON=O,TCN,,,1
and FSOCK=6,20 when activating TCP Listening Server with
AT+SCON=SO,TSN,,1

This works in the laboratory and in field tests.
But our customer assumes now that the TCP timeout is to short for establishing TCP connections from Europe to Australia. I can’t prove it, but can measure a rather short timeout on establishing TCP connection of 5 seconds.

I tried the command AT+FSOCK=1, with no success. The options 6 and 8 are clearly not what we want.
A) Is there a posibility to increase the TCP connect timout?

I also could measure a 10 second TCP timeout after sending a packet to a meanwhile disconnected server.
B) Is it possible to change this value?

Thanks!

Hi, GOHS

Can I get some materials regarding your questions?

–> How did you use the AT command? Did you try like this? ‘AT+FSOCK=1,15000’
If you didn’t, try like that. Or if you did like that, please attach the screenshot to check the DBG messages.

–> I think it is also same things. please try ‘AT+FSOCK=1,20000’ (max.20000ms)

Thanks!:slight_smile:

Hi tom,
thanks for the quick reply.

I used the command like in the Wiki examples
AT+FSOCK=1,10000
and expected a 10 seconds timout, but it remained 5 seconds.

I just tried it once more as You mentioned, just in case…

… manual initialisation, then AP join …
[Link-Up Event]
IP Addr : 192.168.103.42 <- IP from DHCP
Gateway : 192.168.103.254
[OK]
at+fping=5,192.168.103.254 <- ping Gateway
Ping Reply : 40 ms
Ping Reply : 6 ms
Ping Reply : 4 ms
Ping Reply : 4 ms
Ping Reply : 5 ms
[OK]
at+fsock=?
5000,5000,5,100,0,0,0 <- settings at power on
[OK]
at+fsock=1,15000 <- chaged option 1 to 15 seconds
[OK]
AT+SCON=O,TCN,192.168.103.216,5611,1 <- connect to unavailable IP/port
[OK]
… 5 seconds …
[DISCONNECT 0]
at+fsock=?
15000,5000,5,100,0,0,0 <- option 1 ist set as wanted
[OK]

… set up listening server PC running realterm …
at+fsock=1,20000
[OK]
at+fsock=?
20000,5000,5,100,0,0,0 <- option 1 set to 20 seconds
[OK]
AT+SCON=O,TCN,192.168.103.40,5611,1

[CONNECT 0]
[OK]
… sent ‘test’ over Wizfi and received it on PC (realterm) …
… disconnected AP from LAN waited 30 seconds: as expected no change …
… sent ‘t’, then waited ca. 12 (?) seconds until …
[DISCONNECT 0]

In each case the option 1 of FSOCK seems to have no influence on the mentioned timeouts.

Hope this is what You wanted to see.

Hi, GOHS :slight_smile:

I misunderstood some parts.

There is no way to set a TCP timeout value.

As you know, in case of disconnected environment, there is how to reconnect every specific seconds.

  • AT+FSOCK=6,20 -> try to reconnect per 20s

I am sorry for this.

Thanks,

Thanks for the info.

Would be nice if the exact timeouts would be mentioned in the WiFi250 wiki.

Greetings!

would be nice if the commands list and definitions are right describe and update !

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.