WIZnet Developer Forum

issue while Communicationg W3150A+ via 8bit bus

Hello, I’m trying to Read/Write data from/to W3150A+,

I’ve tried several ways to do so but no luck,

whatever i put into Address pin, Data pins stays LOW signal
while i give
/RESET as HIGH
/CS as LOW
/RD as LOW
/WR as HIGH

i simply cannot access W3150A+ :confused:

I haven’t tried SPI Communication

Two things come to my mind:

  • chip is in SPI mode (pin 33 is high);
  • you have problem with clock circuit- it does not function properly and chip is stuck.

Hello Eugeny, thanks for the reply.

I have checked SPI_EN pin again, and it’s tied to GROUND with 0 ohm Resistor

Clock, is oscillating at 25Mhz from -0.5V to +4.0V

Well, I can only guess as you do not provide any info for troubleshooting. Maybe you read locations really having zeroes in them? Maybe some other device also drives the data bus low?

There’s Two W3150+ , which uses same data, address bus! ( different /CS pin )

though i surely made other one’s /CS pin as HIGH,

or can i not use Two W3150+ ?

about the read Location, i’m pretty sure i am reading it correctly, i checked it with oscilloscope…

And if you read another chip it also reads all zeros?

Yes, it does. only zeros

question, Does Address data comes first and Data READ or Write Enable?

or READ/WRITE Enable comes first and Address data?

i just changed it,
( Address Data set, and then READ Enable )

it does gives me data, yet i need to find out it’s legit

See chapter 7 of datasheet.

Problem solved, Thanks you for your help :slight_smile:

1 Like

Please share what the solution is so that others find your solution for similar problems.

It was Timing problem, I changed timing setting and it works fine!

i also had Pin Output/input problem but it was about MCU

1 Like

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.