WIZnet Developer Forum

WIZ107SR need to factory reset module...

Hi. I have two TTL 107SR module, neither of which will respond to the config tool, and they cannot be found.
I CAN ping them on 192.168.1.5, but even a TCP search fails with the config tool.

I would like to force a factory-reset on both of these modules, so I know where I am.
I have tried shorting J1 and also linking nFAC_RST to ground and cycling power, but they are still invisable to the config tool.

Config tool version 1.4.4.1, which seems to be the latest you can get.
Windows 8 Professional 64-bit.
Have also tried using the config tool from Windows XP, but still no comms.

Brand new RS232 versions DO talk to the config tool just fine, but the TTL ones won’t.

This is most likely cos I have setup the TTL ones previously with some setting that makes them hard to find with the config tool, so the easiest solution, would be someway to force a factory reset on both of these modules, so that the config tool will then respond.

Can anyone help?

Hi, Grogster.

The latest version of WIZ107SR module does not support the physical(hardware) factory reset function.
Below links will help you.

If you are having difficulty performing firmware recovery, Please contact the person you purchased the product from and request a RMA.

Hello. :slight_smile:

I have finally had a chance to have another play with this problem, and the other threads are suggesting that the module should be found if I point to 192.168.11.2 as a default IP address.

This is NOT working. I can neither ping 192.168.11.2 nor will the config tool talk to the module on that IP address. The config ping also times out with that IP address.

Can you please give me more exact instructions on what I should be doing to effect a factory reset on these modules. Perhaps I can do something with the MAC address, the sticker with that is still on the top of the module?

Many thanks for any reply. :slight_smile:

Hi, Grogster :slight_smile:

You can recover your WIZ107SR module using factory firmware in below link.

At this time, you have to program the flash memory using the WIZISP tool for W7100A MCU.
Download the WIZISP program via the link below and try to recover your product.

http://www.wiznet.io/wp-content/uploads/wiznethome/Chip/W7100A/Utility/WizISP_Program2.1.1_and_Guide1.0.zip

Below link will help you for using WIZISP tool.

I’ll guide you through a simple product recovery steps.

  1. Connect WIZ107SR and PC via the serial interface. (Check the COM port, If necessary, use USB-RS232 converter)
  2. Reboot the module while shorting 1 and 2 of J1 on board. (Enter MCU boot mode)
  3. Run WIZISP tool and ‘Open’ the serial port
  4. [WIZISP] Select the firmware binary file attached to the link above
  5. [WIZISP] Check the Step 1 ~ 3 of ‘Auto Task Selection’ and then click ‘Go’ button
  6. Reboot your WIZ107SR module

I hope this answer will help you.
Regards,
Eric

Awesome, thank you very much. :slight_smile:
I will try this later tonight and report back.
I also thank you for such a quick reply - was not expecting that. :astonished:

1 Like

Hi there. :slight_smile:

OK, downloaded new firmware OK, but still can’t talk to the module.

In the Config Tool, what should be in the ‘Input code’ box of the search window?
I expect this needs to say something like WIZ107SR or something - I tried that just to see, but no response. :cry:

EDIT: I have tried another module, and I can talk to this one just fine with the config tool. Perhaps the one I have been trying to get working has been damaged or something? I am open to any other suggestions, but I think I will just swap modules for now. I would have quite liked to have got the problem one going again though.

Hi Grogster,

Unfortunately, your module hardware may have suffered damage. If your test the modules on same recovery process but some device does not work, you can suspect damage to a module that is not working.

Request an RMA through our distributor where you purchased the product.
However, if the appearance is damaged, such as soldering marks, or if the product is too old to be purchased, the RMA may be rejected.

Yes, I think that must be the case. :frowning_face:
Oh well. At least I tried.
I will throw this one away and use the other one that IS working. I will have to replace the dead one from your on-line shop. :sunglasses:
Thanks for trying to help me anyway. :new_zealand: :heart_eyes:

G.

1 Like

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.