WIZ550WEB v1.1 - no UART message on startup


#1

Hi All,

I have a WIZnet550WEB development board and desperately trying to “read” the module’s data via the UART port.

Unfortunately, I just get nothing to read in HyperTerminal at module’s startup.

I have checked the UART settings and that the SD card is okay (it seems okay - it came with the dev board).

Am I missing something or doing something wrong?

Roger


#2

Hi flotul.

WIZ550web should display the message as shown below.

However, The message is output when an Ethernet cable is connected.

Thank you.

Scott.


#3

Hello Scott.

I still don’t get anything working.

I really need some help to get started.

The dev board (baseboard)I bought is brand new. Do I really need to update/install, copy something on the SD card or is it read-to-use “out of the box”?

I received help from a collegue, electronician. My colleague and I struggled for hours last week to get the module responding. But no chance at all, we can never get something showing up via UART. We don’t even see the module in our network (no visible IP address or so).

To make sure I don’t overlook something, can you please answer these following questions:

A.- can you tell me how the 7 jumpers on the development board must be set?

B.- I can never see any message coming from the UART port (SUB-d 9 connector) of the dev board even with the connected Ethernet port. Am I missing something?

C.- I don’t really understand the process for flashing the memory. The site says “4. How to WIZ550web Firmware”. Does it mean “how to flash the firmware into the WIZ550web module”? Can you please explain “step-by-step” in other words as in the internet? We want to flash the firmware from the SD card and since we can’t achieve anything up to now, we need a clear description.

We need your help since we cannot spend too many hours on trying to get the module up and running.

Please give us clear guidance .


#4

Hi flotul.

Please read the Wiki… Everything you ask is on the wiki.
http://wizwiki.net/wiki/doku.php?id=products:wiz550web:start

You can check the description at the URL below.
http://wizwiki.net/wiki/doku.php?id=products:wiz550web:wiz550webgsg_en

You can check the description at the URL below and See the base board circuit.
http://wizwiki.net/wiki/doku.php?id=products:wiz550web:wiz550webds_rev1.1_en

The D-sub9 port is not an UART port but an RS-232 port. Do you check with RS-232?

You can check the description at the URL below.
http://wizwiki.net/wiki/doku.php?id=products:wiz550web:wiz550webgsg_en
The SD card is not the place to store the firmware. It is a place to store HTML files.

Scott.


#5

Hi everyone,

Did any of you costumer buy and try one of these development kit?

No offense but, unfortunately, I don’t understand the kind help I get from WIZnet. I might ask things too obvious for them so referring me to their wiki (I already spent hours to read) doesn’t help me at all.

So if I had only two essential questions to help getting me started, they would be:

1.- Is the development kit ready-to-use or not “out-of-the-box”?

2.- There is no visible (no activity on the scope) comm from the RS232 port (SUB-d 9 connector). Do I miss something basic?

Thank you.

Roger


#6

Hello Scott,

-“Please read the Wiki… Everything you ask is on the wiki…”-

-“You can check the description at the URL below…”-

Scott, if I’m asking you, it is because I did all these searches already, and for hours. But your WIKI is not clear to me. O, unfortunately, your answers don’t help at all.

Let me ask again an PLEASE, don’t refer to any wiki link or so; please JUST GIVE ME THE ANSWERS, YOUR ANSWERS.

As long as I cannot “communicate” with the module, I’m stuck. So here are the two most essential questions:

1.- Is the development kit ready-to-use or not?

2.- There is no comm from the UART RS232 port (SUB-d 9 connector) on the dev board. Is the signal inverted?

Thanks a lot for your patience.

Roger


#7

If you ask about how to set the jumpers, YOU lacking basic search/research skills. (like finding the v1.1 datasheet) It’s all there.

Instead we give you a ton of information for every function YOU need to describe what you tried so far.
“I just get nothing” is not helping us.

To get you started here are some questions for you:

  • Did it power on? (yes, I’m serious)
  • Is the LAN port goin on when cable inserted
  • What is the default IP of the module and what IP you tried on the host.
  • What baud-rate did you tried?

#8

Hi Scott,

First, please accept my appologize; I don’t mean to be rude or impolite :blush:

Yes, I went though the wiki described process so my answers are:

  • Did it power on? YES, power is OKAY, LEDs go ON when I power up the board.
  • Is the LAN cable connected. YES, it is. I have connected the board to my router and, since I cannot ping it with i.e. 192.168.11.100, I run an IP lister to see if I can find the WIZ550WEB in my LAN but it doesn’t show up.
  • Is the LAN port blinking. YES, it is blinking.
  • What is the default IP of the module and what IP you tried on the host. I can’t read the default IP address of the module since I cannot get any information via RS232. I have to guess the IP address (192.168.11.100).
  • What baud-rate did you tried? As described in the Wiki: 115200,8,N,1.

Scott, it is not clear to me, even after reading the Wiki, if I need to prepare (do something, load something, update something) the module & baseboard before I can use it. I’m used to buy dev boards and usually they are “ready to use out of the box”.

Thanks a lot for your help and patience :blush:

Have a nice day.

Roger


#9

Hi,

This is not Scot =]

“ready to use out of the box”

They are… read below

You did not mention the IP of the host (the computer) assuming you didn’t change it, you can’t connect to it…

You need to set the PC IP in the same Subnet (192.168.11.xxx), change the IP of the module in the same Subnet of your computer or set it to DHCP and your router will give it one.
This is a thing you need to do for most modules/hardware with a fixed IP for you able to connect to it.

Or go the easy way and download the WIZnet Configuration tool v1.02 to lookup the Wiz500Web and configure it. It should find it regardless what IP it’s set to.

If the webpage is blank you can use FTP (ftp://192.168.11.100) to connect to the module (=SD card) and upload the demo page to it (WIZ550web GitHub Repository Rev1.0) or you can use a random SD card reader.

Next the serial connection…
Note that: you need to use a nul-modem “cross” cable if you connect the devboard to the PC.
(I needed to check the datasheet for you as i don’t have a dev-board)
Not sure if the cable which came with the dev-board is straight or nul-modem. (measure it)

Stop using HyperTerminal and download a proper (debug) terminal like putty, terminal v1.9b, RealTerm, ect. Again, select the proper com port and set to 115200,8,N,1. You should see something magic if you reset the module.

let me know if this works out for you.


#10

Thanks ThaHandy.

I did all you suggested, but still, no “alive” sign from my module/board (altough two LEDs are ON).

You did not mention the IP of the host (the computer)… : I’ve set 192.168.11.111; should be okay.

If the webpage is blank you can use FTP (ftp://192.168.11.100) to connect to the module: browser’s answer is: This site can’t be reached 192.168.11.100 took too long to respond.

Next the serial connection…: the serial cable is a crossed cable (checked!)

Stop using HyperTerminal…: I use TERMINAL. All settings are correct. The only “message” I get on module’s powerup is “<00>” (without quotes) and nothing else, absolutely nothing.

The RJ45’s yellow LED is steady ON. The green LED blinks from time to time (every 5 seconds or so).

Under power, two red LEDs are ON: LED “D3” on the WIZnet module itself and POWER LED “D1” on the baseboard (this board is V1.0 - 2014.09.25).

The WIZ550WEB module is version 1.1.

I removed the module from the board to check the pins - all ok.


#11

Finally, I took the module appart from the baseboard and put it on a breadboard.

First notable changes:

  • three LEDs are now ON on the module (D1+D2 - green and D3 red);
  • I now get (unreadable) serial data on the module’s pin UART1_TX (PIN 14) on POWER-UP - according to the amount of data received, I can imagine that this is the module’s config data.

Still searching how to get proper serial data (inverting signals didn’t change anything up to now).

There is definitively something odd with the baseboard.

If anyone has an idea about what I could try now, it is welcome :wink:


#12

By the way, my module draws 170mA @ 3.3V with connected LAN cable and 120mA without connected LAN cable.

Is this okay?


#13

I was about to mention to remove the module from the base as you mention the module only shows a red LED.

This indicates it’s in BOOT/flash mode. ( sw4 BOOT on the module and sw7 on the dev-board)
I guess there is a short on switch7 on the dev-board forcing the module go in to BOOT-mode somehow.

The module using 3.3V TTL UART signals. Don’t connect it directly to the RS232 port. The output should be the same Scott mentioned.

@ power consumption. that sound about right


#14

I’m using a FTDI USB-RS232 3.3V cable. This allows me to have correct levels and also to invert signals if needed.

Nevertheless, I can’t read any proper data for now.

I checked SW7 on the board and there doesn’t seem to be a short. At least, I can measure an OPEN and CLOSED state of that switch. Doesn’t really matter right now :wink:


#15

@ BOOT pin on the dev-board.
In any chance 3.3V is on that pin? this trigger the BOOT mode

Try change baudrate of “Serial Port - Data” on the demopage until you get readable text (signals are non-inverted)

fyi.
Red = BOOT/ISP mode (9600,8,E) to flash the BOOT and/or APP firmware.
Red and 2 green flashing = App BOOT = TFTP client mode, to download the app firmware.
Red and 2 green = normal (unless you turn off the 2 green led’s in the demo page)


#16

@ BOOT pin on the dev-board. In any chance 3.3V is on that pin? this trigger the BOOT mode : No, PIN is LOW.

Okay, I’ve got something now. I had to set baudrate to 600Bps and I can finally read the data.

HIGH Density Flash memory

=======================================
WIZnet WIZ550web Revision 1.1
Embedded Web Server Module
Firmware Version 2.0.0

Device Name : WIZ550WEB

MAC: 00:08:DC:4F:70:58

IP: 192.168.11.100

GW: 192.168.11.1

SN: 255.255.255.0

DNS: 8.8.8.8

  • Storage mount succeed

  • Type : sFlash

  • Available Memory Size : 973 kB / 973 kB ( 0 kB is used )

  • Storage mount succeed

  • Type : SDHC

  • Available Memory Size : 3863008 kB / 3864064 kB ( 1056 kB is used )


#17

put the content of 0_Basic_Demopages and 1_Get_Set_Functions_Testpage from https://github.com/Wiznet on the root of the SD card (or use the TFP @ Ftp://192.168.11.100)

You will see something like this:

Index of /
img/ 09-05-17 02:00:00
index.html 40.8 kB 23-04-17 02:00:00
func_test.html 28.1 kB 23-04-17 02:00:00

and go to
http://192.168.11.100 and
http://192.168.11.100/func_test.html


#18

Yes ThaHandy,

I can see the files like you describe on my SD.

Nevertheless, trying to view the webpage leads to nothing but a timeout message.

Just to make sure: both sliders (braun switches) on the module must be ON, right? This is how they are when unpacking the module be default, I presume.


#19

ThaHandy,

Thanks a lot for your help but I have to leave for now.

I’ll give it a new try tomorrow :wink:


#20

Util you get the Demopage working, you can set the baudrate by cgi cmd (See here)

Download Curl and apply the following command:

curl -d “baud=8&databit=8&parity=0&stopbit=1&flow=0” http://192.168.11.100/set_uart0info.cgi

This will set port1 to the buadrate 115200 (you can do the same port 2: set_uart1info.cgi)