How to implement Password Wizfi220 + Disconnection problem


#1

Dear Wiznet team,

I’m contacting you since after a long time we finalized our product for music application PEDAL PLAYER (https://www.youtube.com/watch?v=9jTDP4P8Woc&t=2s) with your chip Wizfi220 embedded, I hope you are well and can help me on a couple of issues.

We’re creating the network as follow, AT-commands are:

// “AT”;
// “AT”;
// “AT+WD”;
// “AT+WM=2”;
// “AT+WAUTH=0”;
// “AT+NDHCP=0”;
// “AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1”;
// "AT+WA=PP-SERVER,8, ";
// “AT+DHCPSRVR=1”;
// “AT+NSTCP=5000”;
// “AT+XDUM=0”;

It works and the wirless connection is OK ( the name of the server is PP-SERVER), devices are connected, maximum 3 right?

Now:

1) We would like to introduce the password authentication (WEP,WPA2-PSK,…) and I introduced the at-command like this:

// “AT”;
// “AT”;
// “AT+WD”;
// “AT+WM=2”;

// “AT+WWPA=12345678”;
// “AT+WAUTH=1”;

// “AT+NDHCP=0”;
// “AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1”;
// "AT+WA=PP-SERVER,8, ";
// “AT+DHCPSRVR=1”;
// “AT+NSTCP=5000”;
// “AT+XDUM=0”;

but it doesn’t work…
Where is the mistake?

2) When we use this router in house everything is OK, but when we use it in open space with large audience there is a disconnection of the server and the system cannot work because the network connection disappear automatically.
Attachment a video of the problem (sorry for the italian language messages but I think its clear the problem).
Please note the signal is very strong and I can assure there were no other networks on channel 8 or interferences around the Wizfi220.
May be the fact that if it is an open network all the people are connecting overloading the supported connected devices capacity of your chip?

Thank you for your answer

Davide Stefanon
POOM! Music Labs
davide.stefanon@gmail.com
M. +39.346.490.10.91


#2

Hi, POOM

First of all, thank you for using our chips.

–> It is going to be helpful to you.

If you want to know more specific, please refer to the link below.
http://www.wiznet.io/product-item/wizfi220/ - Programmer’s Guide

–> You mean,
when WizFi220 is used in house without setting password, it works fine.
But, when it is used in open space without setting password, it doesn’t works. right?

From what I know, when it works as a limitedAP mode, there is no differences in house or else.
So, I recommend to set the password to prevent from other people to connect.

Regards,
Tom.


#3

Hi Tom,

for the first problem we will try even if we already followed the example in the guide, but we will try again.

for the second item the problem is without password (OPEN), and as you can see from the attachment video the network is resetting and disappearing from the available connections in our customer’s Android Wi-fi device list.
We suppose its because its an OPEN and LIMITED network and if large audience attempt to connect to it the server can crash and resetting itself, can you confirm? Or which can be the reason? That’s why we want to implement PASSWORD access and keep the connected device to max 3. Do you think we’re on the right way for the solution?

Thanks
Davide


#4

Hi :slight_smile: POOM

Did you set the password as example that I attached?
I think that’ll be work fine.

And, From what I know that is right.

and then ‘attached video’ means your product vedio…? I cannot find the problem at your product video. It looks just product video.

Regards,
Tom.


#5

Hi Tom,

no in the original post I have attached a ZIP file containing the error during an exibithion, did you open it? Or I think was too large and was not included in the post?

We’re working with your Wizfi220 development kit and we’re sending AT-Commands to create our LimitedAP server network.
Yesterday we tested your example but it doesn’t work… so currently we’re at this level:

  1. If we do not put any password (OPEN) the list of commands are the follow and everything is OK with exception of the disconnectin problem when too many devices connected to the Wizfi220 server (as stated in the first post):
    AT
    AT+WD
    AT+WM=2
    AT+WAUTH=0
    AT+NDHCP=0
    AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
    AT+WA=WizFi210-PPlayerPC,8,
    AT+DHCPSRVR=1
    AT+NSTCP=5000
    AT+XDUM=0

  2. With your example it doesn’t work:
    AT
    ATE0
    AT+XDUM=0
    AT+BDATA=1
    AT+WD
    AT+WM=2
    AT+WAUTH=1
    AT+WWEP1=1234567890
    AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
    AT+WA=LimitedAp
    AT+NAUTO=0,1,192.168.3.105,5000
    ATA2

  3. We did some tests according to the manual and starting from your example we were able to build the network but the devices still cannot connect. AT-Commands as follow:
    AT
    AT+XDUM=0
    AT+BDATA=1
    AT+WD
    AT+WM=2
    AT+WAUTH=1
    AT+WWEP1=1234567890
    AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
    AT+WA=LimitedAp, ,8,
    AT+NAUTO=0,1,192.168.3.105,5000
    ATA2

and the network is creating but the device (PC in this case) is not able to connect because it doesn’t receive the IP address in my opinion, so it’s coming back asking AGAIN the password.

Considerations:
a) We removed the Echo since we need to see the command and the answer, not just the answer in our program to load the AT-commands via serial (you will see the video)
b) ATA2 is not accepted as command and the chip answer is [ERROR]
c) we had to add ", , 8, " after the AT+WA=LimitedAp from your example otherwise it doesn’t work
d) in the manual we see that the first parameter of AT+NAUTO for a Server is “1” but in your example you put “0”, is it correct? In any case we tried also with 1 but it still doesn’t work…
e) in AT+NAUTO commands yu gave me this strange IP (192.168.3.105) as server parameter, but in the manual we have different command (AT+NAUTO =1,1,5000) and that’s all. In any case we tried also with this command but it still doesn’t work…

Its impossible to send you the video since max dimension file size is 3Mb. I sent them to wiznet@discoursemail.com

Video Examples

Please let me know if you received it or please give me an email where I can send them to you.

I think we need a direct telephone contact, its really difficult to explain and receive your support only with this forum…

Thanks
Davide
+39.346.490.10.91


#6

Hi ! POOM:)

First of all, I cannot watch your video.
May I get a video with my e-mail?
My e-mail address is ‘tom@wiznet.io’. Or you can use a cloud drive and attach the link.

And then, I apologize for the confusion.
I tested it works well.

I attached the log and AT cmd.

image

/*
AT+WD
AT+WM=2
AT+WAUTH=1
AT+WWEP1=1234567890
AT+NSET=192.168.10.1,255.255.255.0,192.168.10.1
AT+DHCPSRVR=1
AT+WA=LimitedAP_TEST
AT+NAUTO=1,1,5001
ATA2

*/

I hope it is helpful.

Regards,
Tom.


#7

Hi Tom,

I sent you the video examples to your email, please review it and let me know.

We need to sort out soon.

thanks
regards

Davide


#8

Hi Tom,

we tried with your second topic (printscreen in BLUE) and it works very well, finally!

But its really different from the first AT-COMMAND list you gave us at the beginning (see below picture), this doesn’t work at all!
immagine

Now we will test next saturday the network created by Wizfi220 with LARGE AUDIENCE and I will let you know if the disconnection problem of the server will persist or its solved.

Thank you very much for now :slight_smile:
Davide


#9

Hi ! POOM:)

I am glad to hear that ! :slight_smile:

if you have any update please let me know !

Regards,
Tom.


#10

Hi Tom!

Sorry to come back to you again but we still have a problem: we cannot communicate to the server through SERIAL PORT after the device connection to server.

In summary:

  1. We created a network with password based on your script and everything is ok in terms of device connection.
  2. AFTER the last command (ATA2) of the network creation we LOOSE any dialogue with the server from serial port. For example, if we just write “AT” we do not receive the [OK] answer from the Server. No communication at all.
  3. the SCONN LED of the development board is RED (see attachment)20180411_010906

FYI when we implemented the network without the password (open) the serial channel was working properly and the red led was OFF during the communication.

Is there some command to enable the serial communication?

We really appreciate your support.

Thanks
Regards

Davide Stefanon
POOM! Music Labs
davide.stefanon@gmail.com


#11

HI,

Can somebody answer and support please??

Thanks
Regards

Davide


#12

Hi, POOM !

I am apologize for late response.

When you want to change a Data Mode to Command Mode, You should input ‘+++’ without ‘CR LF’.

image

After input ‘+++’, you can use an AT command to WizFi220.

When you want to return to a previous connection, you can use a ‘ATO’.

Regards,
Tom.


#13

Hi

Thanks now it works, but the dialogue between server and device is now encrypted/codified like:

[ESC] [S] [MY COMMAND] [ESC] [E]

We didn’t have such encryption with the “open” network and it was like:

[MY COMMAND]

Is there any instruction to remove such codification? Otherwise we have to change completely our firmware…

Thanks

Davide


#14

Hi, POOM !

If you want to use data mode, you can use an ‘ATO’ command to return to a data mode.


#15

Hi TOM,

I have to apologize but I misunderstood the message from our engineer last time, it is exactly the opposite.

Let me explain:

  1. we create the network well and with password -> the device is connected to the Wizfi220 server correctly.

  2. The last AT command we type (as you suggested in previous email) is ATA2 which we receive [OK] answer

  3. Now, according to your manual we’re already in Data Command BUT our firmware speaks WITH the encoded [ESC][S] {ESC][E] encryption

So finally our task is to switch to AT Command mode.

Reading the manual and according to your feedback we should type the +++ sequence after ATA2 and this will switch to Command mode, but unfortunately it doesn’t work.

We typed +++ without CR/LR and no answer from server (please see attached picture)

So:

  1. Can you check the picture and let us know the exact +++ command line to type? Maybe we miss something… if we type only +++ we do not receive the [OK] answer and nothing happen when we type for example AT (see picture).

  2. You wrote that after +++ we have to re-configure the WizFi220 since the TCP socket connection is lost, I’m sorry but what does it means? I didn’t understood how we have to do that (maybe is the reason why it doesn’t switch to AT Command).
    Looking at your screenshot I see you typed * Connection test nAT* with n=+++ without CR and then AT? Sorry I do not understand your command line at all, do we have to type Connection test +++AT ? Or what?

  3. The second option to switch to AT Command is the HW trigger, what is it and how it works?

  4. The third option is to close the established Auto Connection, can you tell us how to do that?

Thanks for let us know, we really need your help here.

Davide


#16

Hi, POOM !

I use a different tool to make you understand ! :slight_smile:
I hope it is helpful.

I think, when you send a AT cmd, It is added CRLF automatically.

–> You can get an information related with HW trigger in programmer’s guide at 2.1.13. Miscellaneous - ‘AT+XEHT’.

–> I think, it is just close the socket connection. when WizFi220 operates as a data mode and then close the socket, it will change data mode to command mode.

Regards,
Tom.


#17

Hi,

the problem is defenetly solved, but I still have a “strange” issue that I found very common in the web developers.

In SOME CASE and only in some locations (in my house its working but not in an outside open space) the device is well connected to the server BUT my application cannot send/receive messages since “Unable to establish connection. Persistent Rejection of the target computer IP…”, and the Wifi is Connected

Are you aware about this problem and how to solve? Is it something related to my application (built in Visual Studio) or there is some special setting to do into the wiznet250 router net parameters?

Thanks
Davide

Are you aware about this