W5500 effect on tranciver RFM66


#1

Hi to all!
We use w5500 in several projects with almost same function but in different executions(two-layer PCB with EMC shield, 4-layer with two-inner full-gnd layers and most difficult 4-layer with one inner gnd). And in project 4-layer with one inner gnd when w5500 ON it have some RF effect to our tranciver(on foto) - increace noise level near 6dBm. We had checked space near w5500 with probe and have seen many garmonycs of 25 MHz with high level. it’s normal situation? In two-layer PCB with EMC shield, 4-layer with two-inner full-gnd layers we also have same garmonics but with lower level.


#2

Result is clear, but it is not clear what is causing it.

Where exactly the transceiver is?

W5500 external crystal frequency is 25 MHz, and it has internal PLL, thus it is not a surprise.

There must be design/application guide on the WIZnet website, where they discuss the best practices for placing components and routing the board.

You must figure out what exactly is causing an EMI - chip, connector with magnetics, or conductors. I see that you routed LED tracks too close to the big square device on the board - these tracks can be a source of the noise. Magnetics can be the source of EMI, depending on their shielding level and its grounding of the chassis.

In general it is hard to advise much because total layout and components invloved are not clear.


#3


#4

Does it cause any real issues?

Where exactly? W5500 circuitry will emit EMI in any way, at the crystal side or at the PHY side. The main question here, as I see, if it is real problem or not. As a notie, if I am not mistaken, you have WiFi antenna very close to the MagJack.