WIZnet Developer Forum

Wiz750sr EVB TTL not working...please help

Hi,

I have a problem with my Wiz750sr module. first when i connected the status in the configuration tool was “OPEN”. I clicked on “UPDATE” for installing the latest firmware. Then there was an error showing “firmware was not installed” . So two leds(green & Blue ) starts to blink continuously for a very long time. I tried reloading the firmware, but it was not a success. So I searched the net and find that firmware can be uploaded through ISP Tool. So I connected the device in ISP Tool and gave the path of the firmware there and clicked on the ISP button. Then it starts to load memory and shows a dialogue box that “Download Completed” not firmware installed. After that the led’s start to stop blinking and i couldn’t even find my device in the configuration tool or in cmd windows. I used WIZnet MAC tool and entered the MAC ID of the device and Clicked the button" WRITE MAC" . It shown “READ MAC ADDRESS”,“FINISH WRITE MAC ADDRESS”. I tried many methods to make the device to recognize by the configuration tool and to upload the firmware. But it was a not a success. Not the present condition is that the configuration tool cannot recognize the device, no led’s blinking(except the red led for the power), not installed the firmware.

If anyone sees this please reply the solution. It will be a help for me.

Hi, @rathesh.

The two LEDs blinking means that entered the App boot mode.
It seems to have stopped in App boot mode due to a problem during the firmware update.

First, please let me know which version of the firmware and configuration tool did you use.

And there is the Wiki about how to recovery WIZ750SR. Refer to below link.

Thank you.

Hi, @rena
The version of the tool is 0.5.1 Beta, firmware version 1.0.4.

I have tried every method to make a connection with the modeule and the PC, but it is being a failure. i tried to write the mac address nd all.

Tried writing the firmware. It is still not been recognized by the configuration tool. Can you tell me a solution for it.

Hi, @rathesh.

I recommend that use the latest firmware.
Now WIZ750SR Firmware version 1.2.3 is released, please update with ISP Tool and test.

You can get ‘WIZ750SRv123_incl_Boot.bin’ file from below link. (When using ISP Tool, you must use Boot+App F/W file.)

And refer to the ‘Flash Programming using WIZISP Tool’ section of the below link.

If you have a capture file or other material, please attach it.

Hi, @rena

Thankyou for your help. You are really a lifesaver. Finally the device was recognized by the PC. It is now in OPEN state.

It will be a help if you tell me how to connect to arduino and wiz750sr evb ttl for sending data to internet. I have a senor output value “3” from arduino which is a serial value, and i need to sent the value to internet.

Regards,
Rathesh

Hi, @rathesh

I don’t know which sensor is connected to which Arduino board,
Maybe I think you need to connect Arduino-WIZ750SR through serial(uart) for send to sensor data.

If WIZ750SR is received sensor data, it will send to ethernet according to serial to ethernet operation.

Hi @rathesh
Arduino is connected to WIZ750SR-TTL in following way:
Pins 3.3V,Ground, TX,RX of the Arduino are connected to the Vdd, ground, RX, TX pins of the WIZ750SR-TTL in a respective manner using UART protocol as WIZ750 only accepts UART communication protocol(no I2C or SPI).

Hi
I downloaded the wizconfig-V1.3.0 software and when I was connected the WIZ750SR-TTL to the PC(via Rj45 cable) to edit the local IP of the WIZ board, 3 times the software was able to detect the hardware, its MAC address and also was successful in editing the local IP of the WIZ board and also the blue LED was blinking(indicating Ethernet connection successful) . However when today I tried to connect the board, the blue LED was blinking but the WIZ750 board was not getting detected nor its MAC address, and I was unable to edit the local IP. Can somebody please help me in resolving this issue?

I am attaching here the screenshot of the wizconfig-V1.3.0.

Thank you,
Best Regards,
Keshav

Hi @Keshav_Shah,

What is the network setting of the PC running wizconfig?
In a snapshot, I think that the PC did not receive normal IP from AP while it is set to DHCP. (IPs starting with 169.)

Please try setting the IP of the wired Internet of PC as follows.
(Example)

  • IP address: 192.168.11.3
  • Subnet mask: 255.255.255.0
  • Gateway: 192.168.11.1

And if there are multiple network adapters, it may not be possible to search. Because the packet can be sent on a path other than the device.
I recommended to proceed after setting disable for network adapters not in use.

Hi @rena
Thank you for you message.
I was able to figure this mistake a day after I messaged .

However, there is another issue which I am facing since 3 weeks(when I was able to change LocalIP of WZ750) when I was sending the data from the Arduino MEGA2560 board to the WIZ750SR-TTL board and further connecting the PC with WIZ750 using Router(and checking using ping “IP Address” on command prompt). I was shown this message whose screenshot I am attaching here.

If it is comfortable with you, can you please guide me with this issue?

Thank you,
Best Regards,
Keshav Shah

First, 192.168.1.131 isn’t the web page address and you can’t show the receive data.
This is a video of the operation when WIZ750SR is used as a TCP server.
↓↓↓↓↓↓↓↓↓↓ Click the image ↓↓↓↓↓↓↓↓↓↓↓↓
WIZ750SR TCP connection

1 Like

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.