WIZnet Developer Forum

Reliable connection in Limited AP mode

Hello, I have been trying to estabish a connection in Limited AP mode with WizFi210. At first, it works well. After a few times that I power on the device, use it and then power it off, my PC is not able to connect any more (and provides an error message saying “limited access”). When this situation occurs, the only way to have the WizFi210 provide a connection again is to reset the board to the factory defaults and re-enter all settings.

What am I doing wrong ? What is the correct way to have the WizFi-210 provide a reliable LIMITEDAP connection every time I switch it on ?

The settings that I used for my WizFi-210 are the following:

AT&F
ATE0
AT+WD
AT+XEHT=2,1,1,3
AT+XDUM=0
AT+WM=2
AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
AT+DHCPSRVR=1
AT+NAUTO=1,1,5000
AT&W0
AT&Y0
ATC0

Everytime the microcontroller switches the WizFi210 on, it enters the following settings:

AT+WD
AT+WA=LIMITEDAP
ATA2

Everytime the microcontroller switches the WizFi210 off, before removing power, it enters the following settings:

AT+WD
ATC0

As I wrote, this works OK for a few times but then, at a certain point, PC is not able to connect anymore.
Firmware version: 1.1.0.0(W)

Thank you for your help !!!
MauB

Hello MauB

You had better upgrade the F/W.
FW 1.1.0.0 is very old version.

After test it again with latest F/W, please let me know the result.

You can download in below.

http://wiznet.co.kr/Sub_Modules/en/product/product_detail.asp?Refid=730&page=1&cate1=&cate2=&cate3=&pid=1132&cType=2

Thank you, Ssekim.

I loaded the latest F/W but I experienced the same problem: after a few cycles of power-on/use/power-off, the PC wasn’t able to establish a connection with the WizFi module in Limited AP.

I later realized that, after each power off, WizFi210 does not “remember” the setting AT+DHCPSRVR=1. For this reason, I included the AT+DHCPSRVR=1 command into the start-up sequence, that now looks like the following:

AT+WD
AT+NDHCPSRVR=1
AT+WA=LIMITEDAP
ATA2

With this power on sequence, everything seems to be working OK… Does this make sense to you ? Is this a correct behavior of the module and is the above the correct power on sequence ?

Thank you very much for your support !
MauB

Hi MauB

You had better use this command set.

AT&F
ATE0
AT+WD
AT+XEHT=2,1,1,3
AT+XDUM=0
AT+WM=2
AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
AT+DHCPSRVR=1
AT+NAUTO=1,1,5000
[color=#FF0000]AT+WAUTO=2,LIMITEDAP[/color]
AT&W0
AT&Y0
[color=#FF0000]ATC1[/color]

If you input this command, WizFi210 will start Limited AP Mode and open TCP Server(Port:5000) after restart.

Thank you.

[quote=“kaizen”]Hi MauB

You had better use this command set.

AT&F
ATE0
AT+WD
AT+XEHT=2,1,1,3
AT+XDUM=0
AT+WM=2
AT+NSET=192.168.55.1,255.255.255.0,192.168.55.1
AT+DHCPSRVR=1
AT+NAUTO=1,1,5000
[color=#FF0000]AT+WAUTO=2,LIMITEDAP[/color]
AT&W0
AT&Y0
[color=#FF0000]ATC1[/color]

If you input this command, WizFi210 will start Limited AP Mode and open TCP Server(Port:5000) after restart.

Thank you.[/quote]

Hello kaizen,

I used those commands and they worked fine on my WizFi module.

The problem is I can’t reprogram the module after I used those commands, but the module can send data from hyperterminal to Hercules.

Did you have any solutions?

Thank you.

Hi

Because WizFi210 is in “Data Mode”, You can’t reprogram the module after you used those commands.
If you want to change WizFi210 to “Command Mode”, you have to input “+++” without any followed character during more than 1 seconds.

Thank you

[quote=“kaizen”]Hi

Because WizFi210 is in “Data Mode”, You can’t reprogram the module after you used those commands.
If you want to change WizFi210 to “Command Mode”, you have to input “+++” without any followed character during more than 1 seconds.

Thank you[/quote]

Hello kaizen

I did that, but nothing happened. After I entered “+++”, should the “Enter” button pressed?

I read the WizFi 210 Programmers’ Guide, in section 4.1: AT Command, there is statement:
“Transition from Data mode to AT command mode can be done by two method. One is using
SW escape sequence(it is +++) or HW Trigger
and the other is to close the established Auto
Connection session.

Using SW escape sequence is not to close the established Auto Connection session, It just only
to transit its mode to AT command mode in order to execute some AT command.”

What is the method to do the “Italic” one?

Thank you wery much

Hi

For switching command mode, You don’t have to input “Enter” button after use “+++”.
After input “+++”, you must do not input any followed character during more than 1 seconds.

Thank you.

[quote=“kaizen”]Hi

For switching command mode, You don’t have to input “Enter” button after use “+++”.
After input “+++”, you must do not input any followed character during more than 1 seconds.

Thank you.[/quote]

Hi

I did that, but nothing happened. The module just sent data like before. Here is the screenshoot:


I type the command at hyperterminal and waited for more than 1 second, but the module don’t change to command mode.
Is there any different method?

Thank you very much.

Hi

I found your problem. you did disable “SW Trigger” vi AT+XEHT command.
If you want to use sw trigger like “+++”, you have to set 0 of AT+XEHT’s 3rd parameter.


[quote=“kaizen”]Hi

I found your problem. you did disable “SW Trigger” vi AT+XEHT command.
If you want to use sw trigger like “+++”, you have to set 0 of AT+XEHT’s 3rd parameter.

[attachment=0]20140408_161146.jpg[/attachment][/quote]

Hi,

It worked, kaizen.

Thank you very much

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.