W5200 connection problem


#1

Hello wiznet

I have W5200 and i need to solve the situation on the picture attached.
I need to access TCP server .

i have tried many different option but was unsuccesful! if I change the server to Router 1 i am succesfull
Can you please help with the configuration

W5200 version is 0x03 ( VERSIONR )

regards zorz


#2

Hi zorz,

Therefore, W5200 seems to operate normally.

Check your network configuration between Router1 and Router2.

  • What is the external IP address of Router1 ?
    Check the external IP address of Router1 whether is same network with Router2 (192.168.3.x) or not.

  • If the external IP address of Router was not sam network with Router2,
    let me know subnet mask of devices in your network.

Thanks,


#3

Hi,
It seems to be likely to have some problem in subneting.

When gateway 1 maybe 255.255.255.0 and gateway 2 maybe 255.255.0.0, gateway 1 should foreward the different subnet packet to gateway 2.

When both gateway are 255.255.0.0, Because All is used in same network, W5200 should connect normally to TCP server.

For IPv4 subnetting, refer tohttp://en.wikipedia.org/wiki/IPv4_subnetting_reference.

Thanks.


#4

Hi

The routers are checked and work ok … if i change W5200 with a PC i am able to make the connection with the server.

This is my configuration on the W5200

HW address : SET
Source IP: 192.168.4.3
Subnet mask: 255.255.0.0
Gateway address : 192.168.4.1

Destination IP address 192.168.3.20
Destination port: 2020 ( ports are open on the router and port forwarding enabled too )

Selected TCP

when i open the socket ( write 1 to 4001 )it is ok
when i start the connection ( write 4 to the 4001 ) than the Socket status register ( 4003 ) goes back to 0…meaning CLOSED

Soo, what am i doing wrong ? Is the configuration OK ?

regards zorz


#5

Hi,
I think that TCP server send RST packte to SET.
For more information, Capture network with ‘WireShark’ program(it’s free) in both site(SET site and TCP server site), and post it.

Thanks.


#6

hi

Ok i will do this test, but what about the configuration i is OK ?

regards Jože


#7

Your configuration is OK.
As you know already, You did confirm it by replacing W5200 SET with a PC.

Once the connection b/w W5200 and PC is successed, The network configuration is correct.
If PC-to-PC test is OK but W5200-to-PC is not OK, it is likely to have problem in W5200.
I guess you mistaked a few in porting or operation in W5200.

I will wait your captured file.

Thanks.


#8

hi

the question was if the W5200 configuration is OK ?

regards zorz


#9

Yes, the configuration was OK.


#10

hi all

Just wont to the say that the problem was resolved …the issue was in Linksys E3200 router … when i removed it …everything is working now … if i will have the time i will try do ckeck the situation and report …

regads zorz


#11

Hi, zorz.

I’m glad to hear you solved the problem.

Best regards.