WizFi310 Reset fault

#1

현재 WizFi310을 사용중입니다.
MCU를 이용하여 AT 명령을 보내고자 프로그램을 하기 위해 WizFi310에 컴퓨터를 통해 AT 명령을
전송하는 테스트를 하고 있습니다.

회로는 위즈넷에서 제공하는 Reference 회로를 그대로 사용하였습니다.
다만 Reset 포트를 MCU에서 제어 할 수 있도록 하였습니다. 즉, WiFi를 사용하지 않을 경우에는
Reset을 Low로 하여 동작시키지 않고, 필요에 따라 Reset Port를 High로 하여 동작시킨 후 사용하고자
합니다.

그러나, AT 명령을 전송하던 중에 AT+WSET와 AT+WSEC 등 다른 명령은 다 전송이 되어 [OK] 등 다른 응답을 받을 수 있으나, AT+WJOIN을 전송하면 Reset이 되어 버립니다.
실제로 파워스플라이의 전류를 관찰해보면… AT+WJOIN 명령을 던지는 동시에 전류가 0으로 떨어졌다가 재부팅되면서 시리얼로 WiFi310 Version 1.0.3.2 [WIZnet Co.Ltd] 문구가 나오며 다시 시작됩니다.

어떤 문제일까요?

#2

안녕하세요

말씀해 주신 증상의 원인을 파악하기 위해서 몇가지 테스트를 부탁드립니다.

  1. AT+WSCAN 명령시 정상 동작하는지 재부팅 되는지.

  2. WJOIN 시 passphrase 를 잘못 입력한 상태로 시도

  3. 다른 AP에 접속(인증 방식 등을 다르게 해서)

#3

보내주신 내용에 대한 답변 드립니다.

아래를 참조해주시기 바랍니다.

와우시스(WowSys)
주 소 : 경남 김해시 주촌면 소망길 88, 김해의생명센터 114호
휴대폰: 010-2937-0598
이메일: radar@naver.com

WOWSYS Co., Ltd.
Address : #114 Gimhae Bio-Medical Center, 88, Somang-gil, Juchon-myeon, Gimhae-si, Gyeongsangnam-do, Republic of KOREA
Zip-Code : 50969
Mobile-Tel: +82-10-2937-0598
Skype ID : handungchi

#4
  1. AT+WSCAN 명령은 정상적으로 동작됩니다.
  2. passphrase에 대해 알지못합니다.
  3. 다른 AP에도 접속이 되지 않습니다.

AT+WJOIN을 할 경우, Reset이 됩니다. 혹시 회로상에 문제가 있는지요?
Mega8이 필요에 따라 11번 핀으로 WizFi310을 강제로 Reset 하기 위해 두었습니다.
하지만 현재 테스트에서는 11번 핀의 출력을 high 상태로 두었기 때문에 …
별 무리는 없을 것으로 판단됩니다.

WiFi_Sensor_Module_final.pdf (147.6 KB)

#5

AT+WSCAN 명령에서도 열에 8번은 리셋이 도면서 재부팅 됩니다.

#6

AT+WSCAN 및 AT+WJOIN 두 명령에 대해서만 리셋이 되는 현상이 발생합니다.
그리고, passphrase는 어떤 의미인지요?
다른 AP에도 대해서도 동일한 현상입니다.

#7

시리얼 통신속도만 기본 설정값이 115200bps에서 38400bps로 변환하였습니다.
115200 속도에서는 WJOIN 및 WSCAN이 잘 먹힙니다. 그러나 38400에서는 대부분 앞서
명령을 전송할 때마다 Reset 됩니다.

#8

안녕하세요

wifi 모듈쪽 로그를 확인할 수 있으시면, 로그를 전달해주시면 확인해 보도록 하겠습니다.

#9

최근에 보내드린 회로에서 WizFi310과 ATmega8 IC 사이에 연결된 단자를 회로에서 모두 제거하고 첨부한 사진과 같이 AT Command를 전송하면 WizFi310은 정상적으로 동작합니다.
하지만, AT+WSCAN과 AT+WJOIN 명령을 보낼 때에 입력전원 3.3V에 전원 Drop 이 발생합니다.
전원은 Power Supply를 통해 3.3V를 공급하고 있는 상태입니다. 그런데도 불구하고 전압 Drop이 발생합니다. 이를 해결할 방법이 없는지요?