WIZ750SR-110 cannot be searched

#1

Hi, I just unboxed the WIZ750SR-110 connected it using ethernet and the configuration software/tool could detect it. The module had this blue light ON. I then tried updating its firmware which said it was successfully updated but after the update the module is not being searched by the software anymore and the blue light doesn’t appear. Is there anything that I can do to make it work again?

Thank you.

Note: The firmware update file was “ALL” including application and Boot. Don’t know what it means but I thought it was for entire module or something so I just used that for firmware update.

#2

Hi,

You can update the module with the newer firmware.
By the way, the firmware of WIZnet’s serial-to-ethernet moduels consists of App-Boot and App code.
App-Boot is like a supervisor for firmware update via ethernet with WIZnet’s configuration and App is the real application for serial-to-ethernet.
Normally, the module like WIZ750SR-110 has App-Boot already inside.
So, you can update it with a new firmware via ethernet with the Configuration Tool.
In this case, you should upload the firmware marked “Application”, not “All”.
The firmware marked “All” should be uploaded with WIZISP tool.

You downloaded the “All” binary to the application area with Configuration tool. It made a mess of it.

Downloading the “All” binary again to the module with WIZISP tool will fix this problem.

Please refer to the below guide for using WIZISP tool and be sure to use the proper binary file.

wizisp tool

WIZ750SR-1xxv124_incl_Boot.bin1.2.4

Thank you.

James

#3

Thank you for the information James.

I had one more doubt regarding downloading the binary file using ISP. The pins for configuring using ISP are UART TXD and RXD. I could not get any information whether these are TTL or RS232 UART. Although they seem to be directly connected to W7500’s UART pins, I assume they are TTL. I do not want to rely on any assumptions, so can you confirm that do I need a separate module eg. TTL to USB to configure WIZ750SR-110 or can I just map the pins on a USB cable and connect it to the laptop running WIZISP?

Please advise.

#4

Hello,

As you can see above image, J2 is the pins for ISP and UART signal level is 3.3V TTL.
You should use TTL-to-USB to connect to this pins.

Thank you.
BR,

James

#5

Thank you for the information. I did what you asked and now the ethernet module is being sensed by the software on the network.

Although my previous problem was fixed a new issue has surfaced. The MAC address of the device is now FF:FF:FF:FF:FF (it is not the one printed on the board) and any changes that I apply to it are not being saved after I search the device again.

I tried factory resetting the module but the issue still persists.

Can you please suggest what might be going wrong?

#6

Hello,

Please erase all data in Data Flash and write ‘All’ code again.
Erasing Data Flash can be done with WIZISP.

Screenshot_2019-04-25%20products%20w7500%20documents%20appnote%20isptool%20%5BDocument%20Wiki%5D

After then, it shows “Input MAC?” at power-up again.
Then input on the serial port which is the same one used for WIZISP “MC00:08:DC:xx:xx:xx”.
You should input your MAC address printed on your module.

Thank you.
BR,

James.

#7

OK, here is what I did.

  1. Selected COM port @baud rate of 115200 (The device gets detected at this or lower baudrate only)

  2. Clicked on Open. (Serial Open Complete message displayed).

  3. Checked Erase All Data/Code Memory.

  4. Did not check anything in step 3 and step 4.

  5. Entered the path for ‘ALL’ binary file that includes Boot and clicked on Start All Steps. (things that are checked in step 5 are verify after programming, Write Main Flash and Reset).

After running all steps, a message displays firmware upload complete and the serial port closes. I refreshed and connected the serial port again but still did not get any “Input Mac?” message.

Note: my nReset pin from ISP pin header is floating. Also, the WIZISP was not detecting the device and throwing an error to check Boot pin, so I connected Boot to +3.3V and it started working just fine after that.

This is something funny that I observed: (Download Completed yet Firmware still writing)

#8

If you click “OK”, then “W7500 Firmware Writing” dialog will disappear.

By the way, can you show me the messages on the console program?

James.

#9

I hope by console you mean the configuration tool.

This is how it looks like:

#10

Hello,

I meant a terminal program for a console port.
Anyway, I could figure out what you faced.
The developer checked the code but he failed to find the reason.

Can you try to download the “All” binary again with WIZISP.exe under the same conditions like “Erase All Data/Code Memory”?
And please dump the Data Flash area and upload the dumped file to here.
Dump menu is a sub menu of “ISP” menu.

Thank you.
BR,

James.

#11

Hi,

There were two options under ISP -> DUMP -> 1. Main Flash Dump and 2. Data Dump.

I have performed Data Dump and here is the file for it:data_flash.bin (512 Bytes)

#12

Hello,

I read the binary file which you uploaded here and it has all FF’s in the fields for MAC address
Although we investigated carefully, we couldn’t figure out why the MAC address changed to all FF’s.
We want to get that module and investigate it on our side.
Can you check if you can ship it back to us?

Thank you.
BR,

James.