WIZnet Developer Forum

WIZwiki-W7500 program stops after reset

Hello, I have bought WIZwiki-W7500 board. I have a problem with own firmware. Original binaries are working - hardware test binary works, original blinky binary works. No problem.

But my programs are not working. For example blinky program. I try to compile it with mbed online compiler and with platformio too. The program is working about 0.5 second after reset the board. Then it is stopped. So, I get one small blink of the LED, and nothing. I wrote simple program for serial communication - for example write Hello World to serial port. I only get 1 or 2 characters after reset. And, then program is stopped.

Do you have any idea?

Hi~ Clexpert
I am sorry about answering late.
I tried to compile it with mbed web compiler and I also don’t work the wait function. I will check the mbed library code and I’ll tell you as soon as possible.

And I think I wish you test using gcc compiler or IAR or keil.
@teddy

thanks,
irina

1 Like

Hi Irina,

thank you for the response. I solved the issue with online mbed compiler by importing library from:

Following the instructions here:

https://os.mbed.com/platforms/WIZwiki-W7500/#update-or-restore-firmware

Now the compiled code works on this board. But unfortunately I am not able to achieve this in the PlatformIO environment.

1 Like

Hi Clexpert
How about you use mbed studio?
https://os.mbed.com/studio/

It’s compile and debug tool
that gives you blink example.

thanks,
teddy

1 Like

Hi Teddy,

Thank you. I used mbed online and PlatformIO till now. But I installed Mbed Studio just now. I tried blink example. And it looks that it is working right. It works without debug features. I must copy binary manually. But it is working.

1 Like

Hi Clexpert

if connects WIZwiki-W7500 to PC, How cognize the device in Mbed Studio?
image
Is the device recognized as above?

Thanks,
Teddy

Hi Clexpert

Maybe your DAP needs upgrade.
Below is the latest version.

lpc11u35_wizwiki_w7500_if_crc_20170420.bin

https://wizwiki.net/wiki/doku.php?id=products:wizwiki_w7500:start_getting_started:write_firmware_cmsis_dap

Please check your DAP version. and try upgrade.

thanks,
Teddy.

1 Like

Hi Teddy,

thank you very much! Yes, Mbed Studio recognized the board, but I didn’t have the option of debugging. It really was necessary to update the DAP firmware. I don’t know what version I had, the text document shows the same. But I downloaded the firmware and made an update. Since then, the software has been offering debugging and it works.

Thank you so much!

2 Likes