WIZnet Developer Forum

UDP Only Works while Wireshark Running

I used Wireshark to monitor the UDP packets between my PC and W5500 using UDP protocol since day 1.

After figured out all troubles, everything works perfect as expected. I turned off Wireshark, and W5500 does not response.

RECV and SEND_OK interrupts happened, so I know that W5500 received and replied to the command from the PC. However, the PC did not get anything.

From the hardware side, I used switch, hub, and even crossed cable, and the result is the same.

W5500 only works while Wireshark is running.

I switched to TCP/IP protocol and W5500 worked fine without wireshark running.

Any idea and help please?

Thank you.

For your information.

I found an issue here.

The destination MAC was left blank (all zeros). Fill it with the PC MAC, and everything worked well together.

Thanks.

Mtuan

1 Like

Hi~
Mtuan

Iā€™m glad that this issue has been resolved.
If any question arises, please post to the Q&A board again.

thanks,
BR
irina

1 Like

Hi~ Mtuan

In summary,you had test UDP mode after MAC of PC into destination MAC register had saving. is it right?
For your information(about MAC Address) -The following extract is taken from wikipedia site.
image
A universally administered address is uniquely assigned to a device by its manufacturer. The first three octets (in transmission order) identify the organization that issued the identifier and are known as the organizationally unique identifier (OUI).[2] The remainder of the address (three octets for EUI-48 or five for EUI-64) are assigned by that organization in nearly any manner they please, subject to the constraint of uniqueness. A locally administered address is assigned to a device by a network administrator, overriding the burned-in address.

Universally administered and locally administered addresses are distinguished by setting the second-least-significant bit of the first octet of the address. This bit is also referred to as the U/L bit, short for Universal/Local, which identifies how the address is administered. If the bit is 0, the address is universally administered. If it is 1, the address is locally administered. In the example address 06-00-00-00-00-00 the first octet is 06 (hex), the binary form of which is 00000110, where the second-least-significant bit is 1. Therefore, it is a locally administered address.[8] Another example that uses locally administered addresses is the DECnet protocol. The MAC address of the Ethernet interface is changed by the DECnet software to be AA-00-04-00-XX-YY where XX-YY reflects the DECnet network address xx.yy of the host. This eliminates the need for an address resolution protocol since the MAC address for any DECnet host can be simply determined.
thanks,
BR
irina