WIZnet Developer Forum

Transfer Data Between Wiz750SR-TTL and VSP

Hello,

I am trying to transmit data from my micro controller connected to S2E Wiz750SR-TTL and read it out on my computer using a serial terminal device PuTTY via WIZVSP (Server). But I am not able to establish a connection between the S2E (Client) and WIZVSP (Server).

Although, I am able to transmit data by using a TCP/IP client software (Hercules) to WIZVSP and read it on Serial Terminal PuTTY.

Can anyone suggest what am I doing wrong?

Hello,

First, I want you to check if PC receive a response when sends PING to WIZ750SR.

Hello @becky,

Yes I do receive the Ping response at 0% loss.

But on the VSP side running server mode with “Start listening only when local virtual port is open” UNCHECKED, I still cannot see any active connections/remote hosts.

Wiz750SR S2E is configured as a client with my computer’s IP and PORT address as its remote host settings.

Hello @neo.

The firewall may be the problem.

Even if data is transmitted and received when using Hercules in a local PC environment,
When using WIZ750SR-TTL, the connection may not be established due to the firewall problem.

Please turn off the firewall and test it, and let me know if you still have a problem.

Thank you.

@rena: I tried establishing communication after disabling firewall but still no luck.

Although, by setting the WIZ750SR as server and running client mode on VSP the communication works just fine even with the firewall ON.

But for my application, I want WIZ750SR to run as client and VSP to run as server.

@rena I was disabling my antivirus software firewall but after disabling Windows 10 Firewall the connection was established as I wanted. I have added the program to exclusion list but the firewall still seems to be blocking it.

Let me know if you know anything in this regards. Thank you for all the help!

Hello, @neo,

Then, you can set inbound & outbound rules in Windows Defender Firewall.

In the Firewall Advanced settings, set the rule type to port and enter the TCP port to use.
(Range also possible)

Thank you.

Thank you!

It certainly helped me fix the problem!

1 Like