WIZnet Developer Forum

No link and not SPI comms

Hi!

We are designing a board that has the Wiznet5500 as a communications module. In an earlier version of this same board we used the 5100 without any problem, but changing to the new module is not working as expected.

Our schematic is the following

What happens is that, although the signals sent by the uC by SPI are valid (MOSI, SCK, SS) the module does not respond at all in the MISO. We have also tried to bypass the MISO buffer with the same results.

Another thing that happens is that as soon as the board is powered, the two LEDs of the magjack turn on, both the ACT and the LINK, but it does not link if connected to a computer or a switch.

We understand that they are two separate problems. (Link and SPI)

Here I leave a picture of the real circuit:

And here the layout of the PCB on both sides:


We have also verified that we have a 14Mhz signal on the INT line

This same fault is proven in the 20 PCBs that we have ordered to manufacture. Manufacturing has been done in a factory with sufficient quality controls and is the only part of the system that is giving faults.

We are using as magjack the L836-1J1T-43, which is not one of the recommended ones, but which works correctly in another design with an ENC28J60. Could this be a problem?

The oscillator is the LFXTAL010595Cutt

The PCB also has a SPI header attached to the same pins. If in that header we connect the official wiznet w5500 Arduino shield, it works correctly.

Can you give us a hand to determine what may be happening, please?

Thank you so much. Regards:

Check two things: powers (3.3V and 1.2V), and crystal clocking at correct frequency.

What is it?

Must be either design fault, or some bad/incorrect component.

Thanks for your help.

The powers seems to be OK. (3.36V at the output of the regulator and 1.25V on pin 22 (1V20)

I don’t know why I have that signal on pin 36 (INT). Here’s a capture from the oscilloscope:

About the crystal signals looks fine: First one is XI and the second one is XO:


We had to change de crystal to a new that fits better with the w5500. The original gave us some ugly signals… Could have the old crystal broke the w5500?

Here I have a capture from the logic analyzer, in case it helps:

logic

Thanks again for your help.

Most probably not. Try removing pull-up resistors from RSVD pins. Not sure why you have them as they create 2.95V through built-in pull-downs of 85k.

We just left the RSVD signals disconnected (pins 38 to 42) and we have made some progress:

Now when booting without Ethernet cable connected the two LEDs (ACT and LINK) are off.

If we connect an Ethernet cable the LINK LED stays off, although now, for the first time, the computer does recognize LINK. In fact, if we ping or generate any type of traffic, the ACT LED already lights up.

However, we still have no response in the MISO line.

Any other suggestions?

Thanks again for your help.

W5500 does not support auto-MDIX feature

Ensure you use correct cable.

We have tried to make the same change (remove the resistors that we had in RSVD) in the rest of the PCBs and it seems that they work correctly. For some reason the PCB to which we changed the crystal does not work well, but we will investigate.

Thank you very much for your help!

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.