WIZnet Developer Forum

Problems connecting to WIZ752SR-120

I have a WIZ752SR-125, which I have changed the local IP and the gateway address to match my network. It then works fine and I can ping it and send data back and forth.

I also have a WIZ752SR-120, but I have not been able to get it to connect to my network after setting it up the same way.

I notice that the pinouts of the WIZ752SR-120 between the datasheet, schematic, and silkscreen are all different and none of them match the WIZ120SR.

WIZ752SR-120

Datasheet
Pin 1 TX+
Pin 2 TX-
Pin 4 RX-
Pin 5 RX+

Schematic
Pin 1 TX-
Pin 2 TX+
Pin 4 RX-
Pin 5 RX+

Silkscreen
Pin 1 TX-
Pin 2 TX+
Pin 4 RX+
Pin 5 RX-

WIZ120SR
Pin 1 RX-
Pin 2 RX+
Pin 4 TX-
Pin 5 TX+

What is the correct connection between the WIZ752SR-120 and the RJ45?

As the WIZ120SR-EVB was made for the WIZ120SR, is it correct to assume that it does not work with the WIZ752SR-120?

Is there an evaluation board for the WIZ752SR-120?

Thank You - James

Hi, James

Thank you for finding the incorrect information about WIZ752SR-120
And so sorry for being confused.

When I tested WIZ752SR-120 & WIZ120SR-EVB, it worked.
(I configured the module with https://github.com/Wiznet/WIZnet-S2E-Tool-GUI/releases)

I will check the pin details and reply again.

And could you share more details about how to set up WIZ752SR-120 and how to test it ?

Thank you

Dear @JamesMassey

Sorry, there is an error in the datasheet of WIZ750SR-120 and WIZ120SR.

Schematic and Silkscreen are right.

Pin information for WIZ750SR-120 and WIZ120SR are as follows:

Pin 1: TX-
Pin 2: TX+
Pin 3: RX-
Pin 4: RX+

However, the WIZ750SR-120 and WIZ120SR are supported with Auto MDIX, so they operate normally even when TX and RX signals change.

If you have WIZ120SR-EVB, you can use WIZ120SR-EVB.

WIZ750SR-120-EVB does not exist.

Thank you.

Scott

Thank you guys for responding.

I will definitely get a WIZ752SR-EVB and check it out.

Scott, the WIZ752SR-120 board I have in my hand shows the following pin out on the silkscreen:

Pin 1 TX-
Pin 2 TX+
Pin 3 GND
Pin 4 RX+ (Different between schematic and silkscreen)
Pin 5 RX- (Different between schematic and silkscreen)

As far as how I tested:

WIZ752SR-125 Connected PC to UART1 via null modem and used a serial terminal program to change the IP address and the gateway to match my network. I could then ping the board at the fixed IP address I set. I then used a TCP terminal program connected to the same fixed IP address and port for UART1 (5000) to send characters back and forth between the TCP terminal program and the serial terminal program. Everything worked fine.

WIZ752SR-120 Connected UART1 to my micro and sent serial commands to change the IP address and gateway just as I had done on the WIZ752SR-125, and saved the settings (readback correct after power cycle), yet the device does not show up on the network.

Thank you again - I will see what I can learn from the eval board.

James

Hi, JamesMassey

Thank you for the description.
So, you tested WIZ752SR-125’ uart & ethernet communication based on PC connection.
Then you connected WIZ752SR-120 to other MCU board via uart, then… connected WIZ752SR-120 to PC via ethernet?
Am I right?

And… what do you mean the device does not show up on the network?
Is the device WIZ752SR-120?
and dose not show up on the network mean no searching on the wiz config tool (if it is, which tool you use?) ?
Also, I need to know which firmware version you use.

Could you show more the detail to me?

Thank you

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.