Wizfi210 connect


#1

My environment like this,I have two systems.Every system has been made up of MTU and Wizfi210. I want to raelize purpose that one MTU_1 send date to Wizfi210_1 by serial port or SPI(complete),as the same time Wizfi210_1 send data to Wizfi210_2 with AD-hoc(complete),at last the Wizfi210_2 send data to MTU2(complete)and PC(not complete).
The status that when PC communicate to Wizfi210_2 ,the Wizfi210_1 don’t communicate Wizfi210_2, only one client(PC or Wizfi210_1) visit the Wizfi210_2(serve).
If I set the Wizfi210_2 to client, meanwhile set at+nctcp.Wizfi210_1 can connect to Wizfi210_2 ,and Wizfi210_2 also connect to PC(serve),but the PC don’t receive data only connect.
If I set the Wizfi210_2 to serve,Wizfi210_1 and PC only one can connect it.
If I set the Wizfi210_2 to serve like this at+nstcp/at+nstcp,PC can connect,Wizfi210_1 can’t.
Do you have some methods to solve problem?
Thank you!


Wizfi210 connection
#2

Hi

I don’t understand about your environment.
How to connect between WizFi210#2 and PC. Is it TCP?
Or else, is it connected between MCU#2 and PC using Serial Interface?

In other word, Do you want to use case 1 or case 2 or another case?




#3

Thank you for your reply!
I want to choose case1.Selecting TCP,wizfi210#1 can send datato wizfi210#2,wizfi210#2 can send data to PC.But wizfi210#2 can’t send data to wifiz210#1 or wizfi210#1 can’t receive data from wizfi210#2.
These are wizfi210#2 setting
{+++、
at+wd、
at+wm=1、
at+wauth=1,
wizfi210、
at+ndhcp=0、
at+nset=192.168.1.105,255.255.255.0,192.168.1.1、
at+wa=wizfi210,8
at+nctcp=192.168.1.101,5000、
at+nstcp=5000、
at+cid=?
ata2
}
These are wizfi210#1 setting
{+++、
at+wd、
at+wm=1、
at+ndhcp=0、
at+nset=192.168.1.101,255.255.255.0,192.168.1.1
at+wa=wizfi210,8
at+nstcp=5000
ata2
}


#4

Hello wtx

I just tested it and succeeded, Please try it again as below.

<#1>
at+wd
[OK]
at+wm=1
[OK]
at+ndhcp=0
[OK]
at+wauth=0
[OK]
at+nset=192.168.1.101,255.255.255.0,192.168.1.1
[OK]
at+wa=wizfi210,8
IP SubNet Gateway
192.168.1.101: 255.255.255.0: 192.168.1.1
[OK]
at+nauto=1,1,5000
[OK]
ata2
[OK]

<#2>
at+wd
[OK]
at+wm=1
[OK]
at+ndhcp=0
[OK]
at+wauth=0
[OK]
at+nset=192.168.1.102,255.255.255.0,192.168.1.1
[OK]
at+wa=wizfi210,8
IP SubNet Gateway
192.168.1.102: 255.255.255.0: 192.168.1.1
[OK]
at+nauto=0,1,192.168.1.101,5000
[OK]
ata2
[OK]


#5

Hi Wtx,

I want ask you about how can you complete send data from MTU to Wizfi? did your system connecting like this picture http://postimg.org/image/943kqka2r/?


#6

Hi

Yes, You’re right. Maybe, wtx also connect like you.