WIZnet Developer Forum

WDS mode - Spanning Tree packet are filtered

Hi,
I have two WizFi630 in bridge mode:
First configured as “AP”
Second as “Client Mode” (AP Client) and, on WDS page, SSID is correctly configured with SSID of first AP.
Connection is established correctly and devices on both side can communicate.
BUT, Spanning Tree packets don’t pass and this wifi link (theoretically transparent) generate a loop in the network because Spanning Tree cannot works properly (yes, there is another wired cable, I need this configuration for redundancy reason).
Is Something missing in the AP o Client device configuration? Is this is a bug?
Thanks!

Hi mauro,

Enabling the STP packet on the WizFi630 is not supported.

Thanks Daniel for your replay.
I don’t need that APs manage actively the STP, but that bridged link is transparent and that STP packets generated by other devices can pass through the wifi link.
Is this possibile?
Many thanks
Mauro

Sorry, there is no option about STP in the WizFi630.

WizFi630 was discontinued several years ago. and WizFi630A, next model, was discontinued too.
few month ago we released new WizFi630S as a new WizFi630 Series.

WizFi630S is based on OpenWrt linux distribution for wireless device.
I know the OpenWrt supports the STP. and I found the option to enable STP on the Web configuration like below.
but I don’t test this option yet. because I don’t know how to test it.

Copyright © 2017 WIZnet Co., Ltd. All Rights Reserved.